PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE

WINDEV
WindowsLinuxUniversal Windows 10 AppJavaEtats et RequêtesCode Utilisateur (MCU)
WEBDEV
WindowsLinuxPHPWEBDEV - Code Navigateur
WINDEV Mobile
AndroidWidget AndroidiPhone/iPadApple WatchUniversal Windows 10 AppWindows Mobile
Autres
Procédures stockées
XMLAnnuleRecherche (Fonction)
En anglais : XMLCancelSearch
Annule la recherche effectuée par la fonction XMLRecherche.
Versions 15 et supérieures
Android Cette fonction est désormais disponible pour les applications Android.
Nouveauté 15
Android Cette fonction est désormais disponible pour les applications Android.
Android Cette fonction est désormais disponible pour les applications Android.
Versions 17 et supérieures
iPhone/iPad Cette fonction est désormais disponible pour les applications iPhone/iPad.
Nouveauté 17
iPhone/iPad Cette fonction est désormais disponible pour les applications iPhone/iPad.
iPhone/iPad Cette fonction est désormais disponible pour les applications iPhone/iPad.
Versions 18 et supérieures
Widget Android Cette fonction est désormais disponible en mode Widget Android.
Universal Windows 10 App Cette fonction est désormais disponible en mode Windows Store apps.
Nouveauté 18
Widget Android Cette fonction est désormais disponible en mode Widget Android.
Universal Windows 10 App Cette fonction est désormais disponible en mode Windows Store apps.
Widget Android Cette fonction est désormais disponible en mode Widget Android.
Universal Windows 10 App Cette fonction est désormais disponible en mode Windows Store apps.
Versions 21 et supérieures
Universal Windows 10 App Cette fonction est désormais disponible en mode Universal Windows 10 App.
Nouveauté 21
Universal Windows 10 App Cette fonction est désormais disponible en mode Universal Windows 10 App.
Universal Windows 10 App Cette fonction est désormais disponible en mode Universal Windows 10 App.
Exemple
// Recherche de la balise "<prix>"
XMLRecherche("DocXML", "prix", XMLBalise)
TANTQUE XMLTrouve("DocXML") = Vrai
        Info("Balise trouvée " + XMLNomElément("DocXML"))
        XMLSuivant("DocXML")
FIN

// Annule la recherche en cours
XMLAnnuleRecherche("DocXML")

// Reprise d'un parcours standard
XMLPremier("DocXML")
TANTQUE XMLEnDehors("DocXML") = Faux
        // Opérations
        XMLSuivant("DocXML")
FIN
Syntaxe
XMLAnnuleRecherche(<Document XML>)
<Document XML> : Chaîne de caractères (avec guillemets)
Nom du document XML dans lequel la recherche doit être annulée. Ce document contient le code XML et a été créé avec la fonction XMLDocument.
Composante : wd240xml.dll
Version minimum requise
  • Version 9
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire