PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE

Nouveauté WINDEV, WEBDEV et WINDEV Mobile 26 !
WINDEV
WindowsLinuxUniversal Windows 10 AppJavaEtats et RequêtesCode Utilisateur (MCU)
WEBDEV
WindowsLinuxPHPWEBDEV - Code Navigateur
WINDEV Mobile
AndroidWidget AndroidiPhone/iPadWidget iOSApple WatchCatalystUniversal Windows 10 AppWindows Mobile
Autres
Procédures stockées
Permet d'exécuter un traitement sous condition de l'exécution d'une procédure, et en attendant cette exécution, continue d'exécuter le code en cours sans blocage. Ce type d'instruction est utilisé pour réaliser un appel asynchrone d'un Webservice.
Exemple
trackingSearch est un trackSearch
trackingSearchRes est un resultTrackSearch
trackingSearch.accountNumber = 99999999
trackingSearch.consigneesCountry = "FR"
trackingSearch.consigneesZipCode = "37100"
trackingSearch.sendersRef =  "111111"
 
APRÈS trackingSearchRes = TrackingServiceWSService.trackSearch(trackingSearch) FAIRE
SI ErreurDétectée() ALORS
Trace("Echec de l'appel au service Web : " + ErreurInfo(errComplet))
SINON
Trace("Webservice correctement exécuté")
FIN
FIN
Syntaxe
APRES <Résultat> = <Appel au Webservice> FAIRE
<Code exécuté si réponse>
FIN
<Code exécuté après l'appel du Webservice>
<APRES> :
Signale le début du bloc d'instructions.
<Résultat> :
Résultat de l'exécution du Webservice.
<Appel au Webservice> :
Appel de la procédure permettant d'interroger le Webservice.
<Code exécuté si réponse> :
Code exécuté uniquement lorsque le Webservice aura été exécuté et aura envoyé la réponse.
<Code exécuté après l'appel du Webservice> :
Code exécuté directement après l'appel du Webservice (que le webservice ait répondu ou non).
<FIN> :
Signale la fin du bloc d'instructions.
Remarques
  • Cette syntaxe est utilisable uniquement pour l'appel des Webservices.
  • Le paramètre <Code exécuté si réponse> s'exécute comme une procédure de type Callback quand le Webservice aura rendu la main.
Version minimum requise
  • Version 26
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire