DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE

Aide / WLangage / Propriétés WLangage / Propriétés des fenêtres, des pages et de leurs champs
WINDEV
WindowsLinuxUniversal Windows 10 AppJavaEtats et RequêtesCode Utilisateur (MCU)
WEBDEV
WindowsLinuxPHPWEBDEV - Code Navigateur
WINDEV Mobile
AndroidWidget AndroidiPhone/iPadWidget IOSApple WatchMac CatalystUniversal Windows 10 App
Autres
Procédures stockées
La propriété Page permet de manipuler la page chargée dans le champ Page WEBDEV.
Les seules syntaxes autorisées sur cette propriété sont les suivantes :
  • la comparaison à la valeur NULL.
  • l'appel d'une procédure.
Exemple
// On ouvre la fenêtre de facturation
SI Ouvre(FEN_Facturation, NomClient, NomOpération, CompteRendu, Goodies) = Vrai ALORS
// On a facturé, on peut demander à la page WEBDEV de supprimer le véhicule de la liste
WEBDEV_ListeVéhicules.Page.actualise_ligne(nnumligne)
FIN
Syntaxe

Vérifier si une page est chargée dans le champ

SI <Champ Page WEBDEV>.Page = Null ALORS
   ...
   // Le champ ne contient pas de page WEBDEV
   ...
FIN

SI <Champ Page WEBDEV>.Page <> Null ALORS
   ...
   // Le champ contient pas une page WEBDEV
   ...
FIN

Appeler une procédure navigateur de la page

<Champ Page WEBDEV>.Page.NomProcédure()

Appeler une procédure navigateur de la page avec une valeur de retour

APRES MonRésultat = <Champ Page WEBDEV>.Page.NomProcédure() FAIRE
// Utilisation du résultat
FIN
Remarques
  • L'événement "Après chargement de de la page HTML" est appelé lorsque la page WEBDEV est entièrement chargée.
  • Depuis la page WEBDEV, il est possible d'appeler des procédures du champ WINDEV grâce au mot-clé MonChampHôte.
  • Appel de procédure : Il est possible de passer des paramètres à la procédure appelée.
  • Dans la syntaxe 3 (Appeler une procédure navigateur de la page avec une valeur de retour), le retour est asynchrone.
Liste des exemples associés :
WD IntegrationWEBDEVdansWINDEV Exemples didactiques : WD IntegrationWEBDEVdansWINDEV
[ + ] Cet exemple présente la fonctionnalité "WEBDEV dans WINDEV".
Il présente comment insérer un site ou une partie de site ou une page WEBDEV dans une fenêtre WINDEV avec communication bi-directionnelle en WLangage.
L'intégration d'une page WEBDEV directement dans une fenêtre WINDEV a plusieurs utilisations :
- réunir deux existants, un existant WINDEV et un existant WEBDEV,
- permettre la webisation progressive d'une application. Il suffit alors de développer les nouvelles fonctionnalités dans WEBDEV et de les intégrer dans les applications WINDEV existantes.
Version minimum requise
  • Version 28
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire

Dernière modification : 06/09/2023

Signaler une erreur ou faire une suggestion | Aide en ligne locale