PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE

Nouveauté WINDEV Mobile 25 !
  • Propriétés spécifiques à la description des variables de type gpwOAuthParamètres
WINDEV
WindowsLinuxUniversal Windows 10 AppJavaEtats et RequêtesCode Utilisateur (MCU)
WEBDEV
WindowsLinuxPHPWEBDEV - Code Navigateur
WINDEV Mobile
AndroidWidget AndroidiPhone/iPadWidget iOSApple WatchCatalystUniversal Windows 10 AppWindows Mobile
Autres
Procédures stockées
Le type gpwOAuthParamètres permet de définir toutes les informations nécessaires pour s'authentifier au groupware utilisateur via une application utilisant le standard OAuth 2.0. Ces caractéristiques peuvent être modifiées à l'aide de différentes propriétés WLangage.
Ce type de variable doit être passé en paramètre à la fonction gpwAuthLogin. En cas de succès, cette fonction renvoie un Buffer à utiliser avec la fonction gpwConnecteDistant.
Remarque : Pour plus de détails sur la déclaration de ce type de variable et l'utilisation des propriétés WLangage, consultez Déclaration d'une variable.
Exemple
tabOAuthParam est un tableau de gpwOAuthParamètres
tabOAuthParam = gpwListeOAuthParamètres()
SI ErreurDétectée ALORS
Erreur(ErreurInfo())
RETOUR
FIN
 
Paramètres est un gpwOAuthParamètres = tabOAuthParam[1]
sCode est une chaîne = gpwAuthLogin(Paramètres)
SI ErreurDétectée ALORS
Erreur(ErreurInfo())
RETOUR
FIN
 
Utilisateur est un gpwUtilisateur
sToken est une chaîne
(sToken, Utilisateur) = gpwConnecteDistant(Paramètres, sCode)
SI ErreurDétectée ALORS
Erreur(ErreurInfo())
RETOUR
FIN
Remarques

Propriétés spécifiques à la description des variables de type gpwOAuthParamètres

Les propriétés suivantes peuvent être utilisées pour manipuler les informations nécessaires à la demande d'authentification :
Nom de la propriétéType manipuléEffet
ClientIDChaîne de caractèresIdentifiant du client fourni par le service lors de l'enregistrement de l'application.
IdentifiantEntierIdentifiant du provider utilisé.
NomChaîne de caractèresNom du provider utilisé.
TypeConstante de type EntierType de connexion permettant l'authentification :
  • gpwFacebook : Connexion utilisant un compte Facebook.
  • gpwGoogle : Connexion utilisant un compte Google.
  • gpwMicrosoft : Connexion utilisant un compte Microsoft MSN.
  • gpwSalesforce : Connexion utilisant un compte Salesforce.
  • gpwYahoo : Connexion utilisant un compte Yahoo.
URLAuthChaîne de caractèresURL d’autorisation à utiliser (première URL du standard OAuth 2.0).


Remarque : Ces propriétés peuvent être utilisées en utilisant une des deux syntaxes suivantes :
  • <Nom de la variable>..<Nom de la propriété>
  • <Nom de la variable>.<Nom de la propriété>
Version minimum requise
  • Version 25
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire