PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE

  • Gestion des erreurs
  • Application en arrière-plan : Spécificité à partir de Android 10
WINDEV
WindowsLinuxUniversal Windows 10 AppJavaEtats et RequêtesCode Utilisateur (MCU)
WEBDEV
WindowsLinuxPHPWEBDEV - Code Navigateur
WINDEV Mobile
AndroidWidget AndroidiPhone/iPadWidget IOSApple WatchMac CatalystUniversal Windows 10 App
Autres
Procédures stockées
Permet de se connecter au Groupware Utilisateur en utilisant une authentification avec un compte de type Facebook, Google, Microsoft, etc.
Exemple
WINDEVWEBDEV - Code Serveur
Identité est un OpenIDIdentité = gpwAuthLogin(gpwFacebook)
AndroidiPhone/iPad
tabOAuthParam est un tableau de gpwOAuthParamètres
tabOAuthParam = gpwListeOAuthParamètres()
SI ErreurDétectée ALORS
Erreur(ErreurInfo())
RETOUR
FIN
 
Paramètres est un gpwOAuthParamètres = tabOAuthParam[1]
sCode est une chaîne = gpwAuthLogin(Paramètres)
SI ErreurDétectée ALORS
Erreur(ErreurInfo())
RETOUR
FIN
 
Utilisateur est un gpwUtilisateur
sToken est une chaîne
(sToken, Utilisateur) = gpwConnecteDistant(Paramètres, sCode)
SI ErreurDétectée ALORS
Erreur(ErreurInfo())
RETOUR
FIN
Syntaxe
WINDEVWEBDEV - Code Serveur
<Résultat> = gpwAuthLogin(<Type> [, <Indice>])
<Résultat> : Variable de type OpenIDIdentité
Variable de type OpenIDIdentité contenant les informations de l'utilisateur.
<Type> : Constante de type Entier
Type de connexion permettant l'authentification :
gpwConnexionConnexion standard utilisant un utilisateur créé et enregistré.
gpwFacebookConnexion utilisant un compte Facebook.
gpwGoogleConnexion utilisant un compte Google.
gpwMicrosoftConnexion utilisant un compte Microsoft MSN.
gpwSalesforceConnexion utilisant un compte Salesforce.
gpwYahooConnexion utilisant un compte Yahoo.
<Indice> : Entier optionnel
Indice de la connexion personnalisée lors de l'ajout avec la fonction gpwAjouteAuthLogin. Pour utiliser ce paramètre, le paramètre <Type> doit correspondre à la constante gpwConnexion.
Remarque : Les informations de connexion ont été décrites et ajoutées à l'aide de la fonction gpwAjouteAuthLogin.
AndroidiPhone/iPad
<Résultat> = gpwAuthLogin(<Paramètre>)
<Résultat> : Buffer
Code d'identification de l'utilisateur à utiliser avec la fonction gpwConnecteDistant.
<Paramètre> : Variable de type gpwOAuthParamètres
Nom de la variable de type gpwOAuthParamètres contenant les caractéristiques de l'application OAuth à utiliser pour l'authentification.
Remarques

Gestion des erreurs

En cas d'erreur de connexion, la variable ErreurDétectée est à Vrai. L'erreur peut être connue grâce à la fonction ErreurInfo.
Android

Application en arrière-plan : Spécificité à partir de Android 10

A partir de Android 10, il n'est plus possible d'ouvrir une fenêtre lorsque l'application est en arrière-plan.
La fonction gpwAuthLogin peut provoquer l'ouverture d'une fenêtre. Si cette fonction est utilisée alors que l'application est en arrière-plan, une erreur fatale sera générée.
Conseils :
  • Il est possible de savoir si l'application est en arrière-plan grâce à la fonction EnModeArrièrePlan.
  • Si une application a besoin d'interagir avec l'utilisateur alors qu'elle se trouve en arrière-plan, la solution consiste à afficher une notification (via le type Notification). Lors du clic sur la notification, l'application sera remise au premier plan si la propriété ActiveApplication est à Vrai. Il est également possible d'ouvrir une fenêtre depuis la procédure passée à la propriété ActionClic.
Classification Métier / UI : Code neutre
Composante : wd280gpu.dll
Version minimum requise
  • Version 24
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire