PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE

Nouveauté WINDEV Mobile 25 !
WINDEV
WindowsLinuxUniversal Windows 10 AppJavaEtats et RequêtesCode Utilisateur (MCU)
WEBDEV
WindowsLinuxPHPWEBDEV - Code Navigateur
WINDEV Mobile
AndroidWidget AndroidiPhone/iPadWidget iOSApple WatchCatalystUniversal Windows 10 AppWindows Mobile
Autres
Procédures stockées
gpwConnecteDistant (Fonction)
En anglais : gpwRemoteConnect
Permet de connecter un utilisateur distant.
Exemple
tabOAuthParam est un tableau de gpwOAuthParamètres
tabOAuthParam = gpwListeOAuthParamètres()
SI ErreurDétectée ALORS
Erreur(ErreurInfo())
RETOUR
FIN
 
Paramètres est un gpwOAuthParamètres = tabOAuthParam[1]
sCode est une chaîne = gpwAuthLogin(Paramètres)
SI ErreurDétectée ALORS
Erreur(ErreurInfo())
RETOUR
FIN
 
Utilisateur est un gpwUtilisateur
sToken est une chaîne
(sToken, Utilisateur) = gpwConnecteDistant(Paramètres, sCode)
SI ErreurDétectée ALORS
Erreur(ErreurInfo())
RETOUR
FIN
Syntaxe

Connecter un utilisateur distant identifié par son login et son mot de passe Masquer les détails

(<Jeton>, <Utilisateur>) = gpwConnecteDistant(<Login> , <Mot de passe>)
<Jeton> : Chaîne de caractères
Jeton de connexion. Ce jeton doit être utilisé pour se connecter à l'application (3ème syntaxe de la fonction gpwConnecteDistant).
<Utilisateur> : Variable de type gpwUtilisateur
Variable de type gpwUtilisateur contenant les informations de l'utilisateur connecté.
<Login> : Chaîne de caractères (avec guillemets)
Login ou email de connexion.
<Mot de passe> : Chaîne de caractères (avec guillemets)
Mot de passe de l'utilisateur.

Connecter un utilisateur distant via OAuth Masquer les détails

(<Jeton>, <Utilisateur>) = gpwConnecteDistant(<Paramètres> , <Code>)
<Jeton> : Chaîne de caractères
Jeton de connexion. Ce jeton doit être utilisé pour se connecter à l'application (3ème syntaxe de la fonction gpwConnecteDistant).
<Utilisateur> : Variable de type gpwUtilisateur
Variable de type gpwUtilisateur contenant les informations de l'utilisateur connecté.
<Paramètres> : Variable de type gpwOAuthParamètres
Nom de la variable de type gpwOAuthParamètres correspondant aux paramètres de la connexion OAuth pour l'application.
<Code> : Buffer
Code d'identification de l'utilisateur retourné par la fonction gpwAuthLogin.

Re-connecter un utilisateur grâce à son jeton de connexion Masquer les détails

<Utilisateur> = gpwConnecteDistant([<Jeton>])
<Utilisateur> : Variable de type gpwUtilisateur
Variable de type gpwUtilisateur contenant les informations de l'utilisateur connecté.
<Jeton> : Chaîne de caractères optionnelle
Jeton de reconnexion fourni par une des syntaxes précédentes de la fonction gpwConnecteDistant.
Composante : wd250android.jar
Version minimum requise
  • Version 25
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire