PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE

WINDEV
WindowsLinuxUniversal Windows 10 AppJavaEtats et RequêtesCode Utilisateur (MCU)
WEBDEV
WindowsLinuxPHPWEBDEV - Code Navigateur
WINDEV Mobile
AndroidWidget AndroidiPhone/iPadWidget iOSApple WatchCatalystUniversal Windows 10 AppWindows Mobile
Autres
Procédures stockées
Renvoie l'état d'un volet d'onglet dynamique (identifié par son alias).
Exemple
// Récupère la ligne sélectionnée dans un champ Table
nIndice est un entier = TableSelect(TABLE_Client)
SI nIndice = -1 ALORS
ToastAffiche("Vous devez sélectionner un client dans le champ Table")
RETOUR
FIN
 
// Récupère l'identifiant du client
nNumClient est un entier = TABLE_Client.IDCLIENT
 
// Définit l'alias du volet
sAlias est une chaîne = gtaOnglet[nNumClient]
 
// Vérifie si la fiche client n'est pas déjà ouverte
SI sAlias = "" _OU_ OngletEtat(ONG_MonOnglet, sAlias) = voletInexistant ALORS
// Ouvre la fenêtre en modification
gtaOnglet[nNumClient] = ...
OngletOuvre(ONG_MonOnglet, ChaîneConstruit("Fiche client de : %1", ...
TABLE_Client.Nom[nIndice]), FI_Fiche, nNumClient)
SINON
ToastAffiche("Fiche déjà ouverte")
// Active le volet
ONG_MonOnglet = sAlias
FIN
Syntaxe
<Résultat> = OngletEtat(<Champ Onglet> , <Alias>)
<Résultat> : Constante de type Entier
Etat du volet d'onglet dynamique :
voletActifLe volet d'onglet existe et il est attaché à son onglet.
voletFlottantLe volet d'onglet existe et il est détaché.
voletInexistantLe volet d'onglet n'existe pas ou il a été fermé.
<Champ Onglet> : Nom de champ
Nom du champ Onglet à manipuler.
<Alias> : Chaîne de caractères (avec guillemets)
Alias du volet d'onglet dynamique à manipuler. Cet alias peut être récupéré grâce à : Si ce paramètre ne correspond à aucun volet dynamique, la fonction ne fait rien et renvoie une erreur non fatale.
Composante : wd260obj.dll
Version minimum requise
  • Version 20
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire