PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE

PV


  • Propriétés spécifiques à la description des variables de type xmlAttribut
WINDEV
WindowsLinuxUniversal Windows 10 AppJavaEtats et RequêtesCode Utilisateur (MCU)
WEBDEV
WindowsLinuxPHPWEBDEV - Code Navigateur
WINDEV Mobile
AndroidWidget AndroidiPhone/iPadWidget IOSApple WatchMac CatalystUniversal Windows 10 App
Autres
Procédures stockées
Le type xmlAttribut permet de manipuler les attributs d'un noeud dans un document XML.
Ce type de variable est utilisé par :
Remarque : Pour plus de détails sur la déclaration de ce type de variable et l'utilisation des propriétés WLangage, consultez Déclaration d'une variable.
Remarques

Propriétés spécifiques à la description des variables de type xmlAttribut

Les propriétés suivantes peuvent être utilisées pour manipuler une variable de type xmlAttribut :
NomType manipuléEffet
NamespaceVariable de type xmlNamespaceEspace de nommage dans lequel se trouve l'attribut.
Deux attributs de même nom peuvent être définis sur un noeud de document XML s'ils proviennent d'espaces de nommage différents.
NomChaîne de caractères UnicodeNom de l'attribut.
Android Attention : Le nom de l'attribut ne doit pas contenir des caractères accentués.
ValeurChaîne de caractères UnicodeValeur de l'attribut.
VideBooléen
  • Vrai si l'attribut est défini dans un noeud donné,
  • Faux dans le cas contraire.
Cette propriété est accessible en lecture seulement.
AndroidJava Attention : L'ordre d'itération n'est pas nécessairement l'ordre de déclaration des attributs dans le document (généralement les attributs sont listés dans l'ordre alphabétique).
Version minimum requise
  • Version 15
Documentation également disponible pour…
Commentaires
Windev Mobile 24 (Android)
Attention : <mon noeud>..Attribut["toto"]..Vide ne fonctionne sous Android que sur le premier test de l'attribut. Si on fait une deuxième lecture, la réponse est toujours 'faux'

<root>
<item>1</item>
<item toto="ignorer">2</item>
</root>

POUR TOUT opt DE XmlDoc.item
INFO (opt..Texte + " TOTO :" + opt..Attribut["toto"]..vide ? "Absent" SINON "Présent")
FIN
POUR TOUT opt DE XmlDoc.item
INFO (opt..Texte + " TOTO :" + opt..Attribut["toto"]..vide ? "Absent" SINON "Présent")
FIN

Donnera :

1 : Absent
2 : Présent
1 : Présent
2 : Présent
Patrick MOIRE
18 nov. 2019