PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE

  • Sélection d'une ressource
  • Gestion du type de conversion
WINDEV
WindowsLinuxUniversal Windows 10 AppJavaEtats et RequêtesCode Utilisateur (MCU)
WEBDEV
WindowsLinuxPHPWEBDEV - Code Navigateur
WINDEV Mobile
AndroidWidget AndroidiPhone/iPadWidget iOSApple WatchCatalystUniversal Windows 10 AppWindows Mobile
Autres
Procédures stockées
URIRécupèreInfo (Fonction)
En anglais : URIGetInfo
Récupère des informations sur une ressource de type URI.
Versions 25 et supérieures
iPhone/iPad Cette fonction est désormais disponible pour les applications iPhone/iPad.
Nouveauté 25
iPhone/iPad Cette fonction est désormais disponible pour les applications iPhone/iPad.
iPhone/iPad Cette fonction est désormais disponible pour les applications iPhone/iPad.
Exemple
AndroidWidget Android
// Ouvre la fenêtre système pour la sélection d'une ressource
UriRessource est une URI = URISélecteur()
SI PAS ErreurDétectée ALORS
// Affiche le nom de la ressource sélectionnée
Info(URIRécupèreInfo(UriRessource, uriInfoNom))
FIN
AndroidWidget Android
// Sauvegarde d'une ressource avec conversion
UriRessource est une URI = URISélecteur()
SI PAS ErreurDétectée ALORS
// Récupère le type MIME dans lequel la ressource peut être convertie
sTypeMIME est une chaîne = URIRécupèreInfo(UriRessource, uriInfoTypeConversion)
SI sTypeMIME <> "" ALORS
// S'il y a plusieurs types MIME possibles
SI ChaîneOccurrence(sTypeMIME, TAB) > 1 ALORS
// Demander à l'utilisateur de choisir le type à utiliser
...
FIN
// Enregistre la ressource sur l'appareil
URIVersFichier(UriRessource, SysRepStockageExterne(1, sseAppDocument), ...
ProcFinEnregistre, sTypeMIME)
PROCÉDURE INTERNE ProcFinEnregistre(bResultat, sCheminRessource)
SI bResultat ALORS
ToastAffiche(ChaîneConstruit("Fichier enregistré (%1)", ...
sCheminRessource))
FIN
FIN
FIN
FIN
Syntaxe
<Résultat> = URIRécupèreInfo(<URI> , <Information>)
<Résultat> : Chaîne de caractères ou Entier
Information demandée.
En cas d'erreur, la variable ErreurDétectée est à Vrai. Pour plus de détails sur l'erreur, utilisez la fonction ErreurInfo.
<URI> : Variable de type URI ou Chaîne de caractères
Nom de la variable de type URI ou chaîne de caractères identifiant la ressource manipulée.
<Information> : Constante de type Entier
Type d'information demandé :
uriInfoNomNom de la ressource (sans extension).
uriInfoTailleTaille de la ressource. <Résultat> correspondra à un entier :
  • Taille de la ressource (en octets).
  • -1 si la taille n'est pas connue ou ne peut pas être récupérée.
uriInfoTypeConversion Types MIME (et extensions de fichier correspondantes) dans lesquels la ressource peut être convertie lors de son export. Dans ce cas, <Résultat> correspondra à une chaîne de caractères au format :
<Type MIME> + TAB + <Extension>

Exemple : "application/pdf + TAB + .pdf"
Si plusieurs types sont renvoyés par la fonction, ils seront séparés par RC.
Pour plus de détails, consultez les Remarques de cette page.
uriInfoTypeOrigineType MIME d'origine de la ressource et extension de fichier correspondante. Dans ce cas, <Résultat> correspondra à une chaîne de caractères au format :
<Type MIME> + TAB + <Extension>

Exemple : "application/pdf + TAB + .pdf"
Remarques

Sélection d'une ressource

Pour sélectionner une ressource et obtenir son URI, utilisez par exemple la fonction URISélecteur.

Gestion du type de conversion

La constante uriInfoTypeConversion permet de récupérer les types MIME dans lesquels la ressource peut être convertie.
Cette information est particulièrement utile lors de l'utilisation des fonctions URIVersFichier et URIVersBuffer pour déterminer le format dans lequel la ressource va être récupérée. En effet, lors de la sélection d'une ressource qui ne provient pas du système de fichier de l'appareil, le fournisseur de contenu (Content Provider) qui gère la ressource peut avoir besoin de convertir cette ressource.
C'est en général le cas si aucune application de l'appareil ne sait gérer le format d'origine de la ressource. Si la ressource peut être exportée sans conversion, la fonction URIRécupèreInfo retournera la même valeur qu'avec la constante uriInfoTypeOrigine.
Exemple :
un fichier Microsoft Word (.doc ou .docx) est sélectionné avec la fonction URISélecteur. Ce fichier se trouve sur Google Drive et aucune application sur l'appareil ne sait gérer ce type de document. Lors de la sauvegarde de cette ressource le fournisseur de contenu convertira automatiquement cette ressource au format PDF. Dans ce cas, la fonction URIRécupèreInfo utilisée avec la constante uriInfoTypeConversion renverra la chaîne "application/pdf + TAB + .pdf".
Composante : wd250android.jar
Version minimum requise
  • Version 24
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire