PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE

  • Propriétés spécifiques à la description des variables de type URI
  • Fonctions manipulant les variables de type URI
WINDEV
WindowsLinuxUniversal Windows 10 AppJavaEtats et RequêtesCode Utilisateur (MCU)
WEBDEV
WindowsLinuxPHPWEBDEV - Code Navigateur
WINDEV Mobile
AndroidWidget AndroidiPhone/iPadWidget iOSApple WatchCatalystUniversal Windows 10 AppWindows Mobile
Autres
Procédures stockées
URI (Type de variable)
En anglais : URI
Le type URI (Uniform Resource Identifier) permet d'identifier une ressource physique (ex : un fichier) ou abstraite (ex : une page Web).
Il existe deux types d'URI :
  • Les URL (Uniform Resource Locator) : identifient une ressource à travers son moyen d'accès et son emplacement.
    Exemples :
    • Adresse web : https://www.pcsoft.fr/windevmobile/index.html
    • Emplacement d'un fichier sur disque : file:///C:/Users/johndoe/Documents/log.txt
  • Les URN (Uniform Resource Name) : identifient une ressource par son nom. Elles ne permettent pas de localiser la ressource mais doivent rester uniques et persister même si la ressource cesse d'exister ou devient indisponible.
    Exemple : Numéro ISBN d'un livre : urn:isbn:0-395-36341-1
Une URI peut être représentée sous la forme d'une chaîne de caractères dont la syntaxe respecte la norme définie par la RFC 3986. Chaque URI peut contenir jusqu'à cinq parties :
<schéma> : [//<autorité>]<chemin>[? <requête>] [ # <fragment> ]
  • Le schéma (ou URI Scheme) est une lettre suivie de n'importe quelle combinaison de lettres, de chiffres, du signe plus (+), du point (.) ou d'un tiret (-) et se termine par deux points (:). Dans le cas d'une URL, il correspond généralement au protocole à utiliser pour accéder à la ressource : http, https, ftp, etc.
  • La partie autorité de l'URI est une partie optionnelle qui correspond aux informations d'identification pour l'accès à la ressource. Elle est en général de la forme :
    [<utilisateur>[:<mot de passe>]]hôte[:<port>]
  • Le chemin est une suite de segments séparés par des slash (/). Dans le cas d'une URL sur une page Web par exemple, il représente le chemin d'accès la ressource sur l'hôte.
  • La requête est une partie optionnelle précédée d'un '?' et suivie d'un ensemble de couples 'clé=valeur' séparés par '&'. Dans le cas d'une URL sur une page Web par exemple, elle permet de passer des paramètres nommés à la page.
  • Le fragment est une partie optionnelle précédée d'un '#' qui permet de fournir des informations supplémentaires permettant d'accéder à une ressource secondaire (numéro de page, ancre d'une page HTML, etc.).
Exemple d'URI :
Remarque : Pour plus de détails sur la déclaration de ce type de variable et l'utilisation des propriétés WLangage, consultez Déclaration d'une variable.
Versions 25 et supérieures
iPhone/iPad Ce type de variable est désormais disponible pour les applications iPhone/iPad.
Nouveauté 25
iPhone/iPad Ce type de variable est désormais disponible pour les applications iPhone/iPad.
iPhone/iPad Ce type de variable est désormais disponible pour les applications iPhone/iPad.
Exemple
AndroidWidget Android
// Ouvre la fenêtre système pour la sélection d'une image
UriRessource est une URI = URISélecteur(uriImage)
SI PAS ErreurDétectée ALORS
// Chargement de la ressource
URIVersBuffer(UriRessource, ProcChargement)
PROCÉDURE INTERNE ProcChargement(bResultat, buffer)
SI bResultat ALORS
// Enregistrement de l'image dans la base de données
HAttacheMémo(Client, Photo, buffer)
HModifie(Client)
FIN
FIN
FIN
Versions 25 et supérieures
iPhone/iPad
// Ouvre la fenêtre système pour la sélection d'une image
URISélecteur(MaProcURISélecteur, uriImage)
 
PROCÉDURE INTERNE MaProcURISélecteur(Succès, UriRessource)
SI Succès = Vrai ALORS
// Chargement de la ressource
URIVersBuffer(UriRessource, ProcChargement)
PROCÉDURE INTERNE ProcChargement(bResultat, buffer)
SI bResultat ALORS
// Enregistrement de l'image dans la base de données
HAttacheMémo(Client, Photo, buffer)
HModifie(Client)
FIN
FIN
FIN
FIN
Nouveauté 25
iPhone/iPad
// Ouvre la fenêtre système pour la sélection d'une image
URISélecteur(MaProcURISélecteur, uriImage)
 
PROCÉDURE INTERNE MaProcURISélecteur(Succès, UriRessource)
SI Succès = Vrai ALORS
// Chargement de la ressource
URIVersBuffer(UriRessource, ProcChargement)
PROCÉDURE INTERNE ProcChargement(bResultat, buffer)
SI bResultat ALORS
// Enregistrement de l'image dans la base de données
HAttacheMémo(Client, Photo, buffer)
HModifie(Client)
FIN
FIN
FIN
FIN
iPhone/iPad
// Ouvre la fenêtre système pour la sélection d'une image
URISélecteur(MaProcURISélecteur, uriImage)
 
PROCÉDURE INTERNE MaProcURISélecteur(Succès, UriRessource)
SI Succès = Vrai ALORS
// Chargement de la ressource
URIVersBuffer(UriRessource, ProcChargement)
PROCÉDURE INTERNE ProcChargement(bResultat, buffer)
SI bResultat ALORS
// Enregistrement de l'image dans la base de données
HAttacheMémo(Client, Photo, buffer)
HModifie(Client)
FIN
FIN
FIN
FIN
Remarques

Propriétés spécifiques à la description des variables de type URI

Les propriétés suivantes peuvent être utilisées pour manipuler une variable de type URI :
Nom de la propriétéType manipuléEffet
AutoritéChaîne de caractères
  • Partie "autorité" de l'URI,
  • Chaîne vide si non spécifiée.
Cette propriété est disponible en lecture seulement.
CheminChaîne de caractèresChemin de l'URI.
Cette propriété est disponible en lecture seulement.
FragmentChaîne de caractères
  • Fragment de l'URI,
  • Chaîne vide si non spécifié.
Cette propriété est disponible en lecture seulement.
HôteChaîne de caractères
  • Hôte de l'URI,
  • Chaîne vide si non spécifié.
Cette propriété est disponible en lecture seulement.
MotDePasseUtilisateurChaîne de caractères
  • Mot de passe de l'utilisateur,
  • Chaîne vide si non spécifié.
Cette propriété est disponible en lecture seulement.
PortEntier
  • Numéro de port,
  • 0 si non spécifié.
Cette propriété est disponible en lecture seulement.
RequêteChaîne de caractères
  • Requête présente dans l'URI,
  • Chaîne vide si non spécifiée.
Cette propriété est disponible en lecture seulement.
SchémaChaîne de caractèresSchéma présent dans l'URI.
Cette propriété est disponible en lecture seulement.
UtilisateurChaîne de caractèresNom d'utilisateur.
Cette propriété est disponible en lecture seulement.
ValeurChaîne de caractèresURI complète.

Remarque : Ces propriétés peuvent être utilisées en utilisant une des deux syntaxes suivantes :
  • <Nom de la variable>..<Nom de la propriété>
  • <Nom de la variable>.<Nom de la propriété>

Fonctions manipulant les variables de type URI

Les fonctions suivantes manipulent des variables de type URI :
Versions 24 et supérieures
URIRécupèreInfo
Nouveauté 24
URIRécupèreInfo
URIRécupèreInfo
Récupère des informations sur une ressource de type URI.
Versions 24 et supérieures
URISélecteur
Nouveauté 24
URISélecteur
URISélecteur
Ouvre une fenêtre du système pour sélectionner une ressource provenant :
  • du système de fichiers de l'appareil,
  • du Cloud (Google Drive, Microsoft OneDrive, etc.)
  • ou d'un des gestionnaires de contenu installés sur l'appareil.
Versions 24 et supérieures
URIVersBuffer
Nouveauté 24
URIVersBuffer
URIVersBuffer
Charge en arrière-plan le contenu d'une ressource (image, texte, etc.) identifiée par son URI dans une variable de type buffer.
Versions 24 et supérieures
URIVersFichier
Nouveauté 24
URIVersFichier
URIVersFichier
Enregistre en arrière-plan le contenu d'une ressource (image, texte, etc.) identifiée par son URI dans un fichier externe.
Pour réinitialiser le contenu d'une variable de type URI, il est possible d'utiliser la fonction VariableRAZ.
Voir Aussi
Version minimum requise
  • Version 24
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire