PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE

WINDEV
WindowsLinuxUniversal Windows 10 AppJavaEtats et RequêtesCode Utilisateur (MCU)
WEBDEV
WindowsLinuxPHPWEBDEV - Code Navigateur
WINDEV Mobile
AndroidWidget AndroidiPhone/iPadWidget iOSApple WatchCatalystUniversal Windows 10 AppWindows Mobile
Autres
Procédures stockées
URIVersFichier (Fonction)
En anglais : URIToFile
Enregistre en arrière-plan le contenu d'une ressource (image, texte, etc.) identifiée par son URI dans un fichier externe.
Versions 25 et supérieures
iPhone/iPad Cette fonction est désormais disponible pour les applications iPhone/iPad.
Nouveauté 25
iPhone/iPad Cette fonction est désormais disponible pour les applications iPhone/iPad.
iPhone/iPad Cette fonction est désormais disponible pour les applications iPhone/iPad.
Exemple
AndroidWidget Android
// Ouvre la fenêtre système pour la sélection d'un pdf
UriRessource est une URI = URISélecteur("application/pdf")
SI PAS ErreurDétectée ALORS
// Enregistre la ressource dans le répertoire de l'application
URIVersFichier(UriRessource, "document.pdf", ProcEnregistre)
PROCÉDURE INTERNE ProcEnregistre(bResultat, sChemin)
SI bResultat ALORS
ToastAffiche("Enregistrement terminé")
SINON  
ToastAffiche("Echec de l'enregistrement")
FIN
FIN
FIN
AndroidWidget Android
// Sauvegarde d'une ressource avec conversion
UriRessource est une URI = URISélecteur()
SI PAS ErreurDétectée ALORS
// Récupère le type MIME dans lequel la ressource peut être convertie
sTypeMIME est une chaîne = URIRécupèreInfo(UriRessource, uriInfoTypeConversion)
SI sTypeMIME <> "" ALORS
// S'il y a plusieurs types MIME possibles
SI ChaîneOccurrence(sTypeMIME, TAB) > 1 ALORS
// Demander à l'utilisateur de choisir le type à utiliser
...
FIN
// Enregistre la ressource sur l'appareil
URIVersFichier(UriRessource, SysRepStockageExterne(1, sseAppDocument), ...
ProcFinEnregistre, sTypeMIME)
PROCÉDURE INTERNE ProcFinEnregistre(bResultat, sCheminRessource)
SI bResultat ALORS
ToastAffiche(ChaîneConstruit("Fichier enregistré (%1)", ...
sCheminRessource))
FIN
FIN
FIN
FIN
Syntaxe
URIVersFichier(<URI> , <Chemin> , <Procédure> [, <Type MIME>])
<URI> : Variable de type URI ou chaîne de caractères
Variable de type URI ou chaîne de caractères identifiant la ressource à sauver.
<Chemin> : Chaîne de caractères
Correspond :
  • Soit à un chemin de répertoire (ce répertoire doit exister) : la ressource sera enregistrée dans ce répertoire. Le nom du fichier créé correspondra au nom d'origine de la ressource et son extension dépendra du format utilisé pour la sauvegarde (voir notes).
  • Soit à un chemin complet ou relatif de fichier. Si le fichier existe déjà, il sera écrasé.
    Attention : l'extension du fichier ne sera pas modifiée même si la ressource a dû être convertie dans un autre format pour l'enregistrement.
Le chemin complet du fichier de sauvegarde sera passé en paramètre de la procédure appelée à la fin de l'enregistrement.
<Procédure> : Nom de procédure WLangage
Nom de la procédure WLangage (également nommée "callback") appelée à la fin de l'enregistrement. Cette procédure est de la forme :
PROCEDURE <Nom de la procédure>(<Résultat>, <Chemin>)
où :
  • <Résultat> est un booléen :
    • Vrai si l'enregistrement a été effectué,
    • Faux dans le cas contraire. Pour récupérer le détail de l'erreur, utilisez la fonction ErreurInfo avant tout autre appel à une fonction WLangage (ce qui réinitialiserait l'erreur).
  • <Chemin> est une chaîne de caractères correspondant au chemin complet du fichier utilisé pour l'enregistrement.
<Type MIME> : Chaîne de caractères optionnelle
Type MIME correspondant au format dans lequel la ressource doit être enregistrée (voir Remarques).
Si ce paramètre n'est pas précisé ou correspond à une chaîne vide (""), la ressource sera enregistrée dans son format d'origine si possible ou bien elle sera préalablement convertie dans un format par défaut.
Remarques
  • Pour sélectionner une ressource et obtenir son URI, utilisez par exemple la fonction URISélecteur.
  • Lorsque la ressource à enregistrer ne provient pas du système de fichier de l'appareil, le fournisseur de contenu (Content Provider) qui gère la ressource peut avoir besoin de convertir cette ressource. C'est en général le cas si aucune application de l'appareil ne sait gérer le format d'origine de la ressource. Il est possible de préciser le format de conversion de la ressource en renseignant le paramètre <Type MIME>. Pour connaître le type MIME dans lequel une ressource peut être convertie, utilisez la fonction URIRécupèreInfo avec la constante uriInfoTypeConversion. Si cette fonction renvoie une chaîne vide (""), la ressource ne peut pas être enregistrée. Dans ce cas, il ne faut pas appeler la fonction URIVersFichier sur cette ressource car elle échouera.
    Exemple :
    un fichier Microsoft Word (.doc ou .docx) est sélectionné avec la fonction URISélecteur. Ce fichier se trouve sur Google Drive et aucune application sur l'appareil ne sait gérer ce type de document. Lors de l'enregistrement de cette ressource le fournisseur de contenu convertira automatiquement cette ressource au format PDF. Dans ce cas, la fonction URIRécupèreInfo utilisée avec la constante uriInfoTypeConversion renverra la chaîne "application/pdf + TAB + .pdf".
Composante : wd250android.jar
Version minimum requise
  • Version 24
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire