PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE

  • Manipulation d'une balise associée à un espace de nommage
  • Fonctions XML et threads
WINDEV
WindowsLinuxUniversal Windows 10 AppJavaEtats et RequêtesCode Utilisateur (MCU)
WEBDEV
WindowsLinuxPHPWEBDEV - Code Navigateur
WINDEV Mobile
AndroidWidget AndroidiPhone/iPadWidget iOSApple WatchCatalystUniversal Windows 10 AppWindows Mobile
Autres
Procédures stockées
XMLNamespace (Fonction)
En anglais : XMLNamespace
Renvoie le préfixe de l'espace de nommage de la balise courante dans un document XML.
Versions 15 et supérieures
Android Cette fonction est désormais disponible pour les applications Android.
Nouveauté 15
Android Cette fonction est désormais disponible pour les applications Android.
Android Cette fonction est désormais disponible pour les applications Android.
Versions 17 et supérieures
iPhone/iPad Cette fonction est désormais disponible pour les applications iPhone/iPad.
Nouveauté 17
iPhone/iPad Cette fonction est désormais disponible pour les applications iPhone/iPad.
iPhone/iPad Cette fonction est désormais disponible pour les applications iPhone/iPad.
Versions 18 et supérieures
Widget Android Cette fonction est désormais disponible en mode Widget Android.
Universal Windows 10 App Cette fonction est désormais disponible en mode Windows Store apps.
Nouveauté 18
Widget Android Cette fonction est désormais disponible en mode Widget Android.
Universal Windows 10 App Cette fonction est désormais disponible en mode Windows Store apps.
Widget Android Cette fonction est désormais disponible en mode Widget Android.
Universal Windows 10 App Cette fonction est désormais disponible en mode Windows Store apps.
Versions 21 et supérieures
Universal Windows 10 App Cette fonction est désormais disponible en mode Universal Windows 10 App.
Nouveauté 21
Universal Windows 10 App Cette fonction est désormais disponible en mode Universal Windows 10 App.
Universal Windows 10 App Cette fonction est désormais disponible en mode Universal Windows 10 App.
Exemple
MonDoc est une chaîne
MonDoc = fChargeTexte("Exemple.xml")
XMLDocument("exemple", MonDoc)
SI ErreurDétectée = Vrai ALORS
Erreur("Le fichier n'est pas au format XML")
RETOUR
FIN
// On se positionne sur la première balise du fichier
SI XMLPremier() = Vrai ALORS
SI XMLNamespace() <> "" ALORS
Info("Le préfixe utilisé pour l'espace de nommage est : " + XMLNamespace(), ...
"L'URI correspondante est : " + XMLNamespaceURI())
SINON
SI ErreurDétectée = Vrai ALORS
Info("L'élément lu n'est pas une balise")
  SINON
Info("La balise ne contient pas d'espace de nommage")
FIN
FIN
FIN
XMLTermine()
Syntaxe
<Résultat> = XMLNamespace([<Document XML>])
<Résultat> : : Chaîne de caractères
  • Préfixe de l'espace de nommage utilisé pour la balise en cours,
  • Chaîne vide ("") :
    • si la balise ne contient pas de préfixe de nommage.
    • si le document XML n'est pas positionné sur une balise. La variable ErreurDétectée est à Vrai.
<Document XML> : : Chaîne de caractères optionnelle (avec guillemets)
Nom du document XML à manipuler. Ce document contient le code XML et a été créé avec la fonction XMLDocument. Si ce paramètre n'est pas précisé, la fonction XMLNamespace s'applique au dernier document XML manipulé dans le thread en cours.
Remarques

Manipulation d'une balise associée à un espace de nommage

  • Une balise associée à un espace de nommage peut être manipulée grâce aux fonctions XMLDonnée, XMLExtraitChaîne, ...
  • La fonction XMLNamespaceURI permet d'obtenir l'URI de définition de l'espace de nommage.

Fonctions XML et threads

Si votre application utilise des threads, le document XML est partagé entre tous ces threads. Pour plus de détails sur la gestion des threads, consultez Gestion des threads.
Classification Métier / UI : Code neutre
Composante : wd250xml.dll
Version minimum requise
  • Version 10
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire