PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE

WINDEV
WindowsLinuxUniversal Windows 10 AppJavaEtats et RequêtesCode Utilisateur (MCU)
WEBDEV
WindowsLinuxPHPWEBDEV - Code Navigateur
WINDEV Mobile
AndroidWidget AndroidiPhone/iPadApple WatchUniversal Windows 10 AppWindows Mobile
Autres
Procédures stockées
XMLRésultat (Fonction)
En anglais : XMLResult
Donne le résultat d'une requête XPath de calcul. Cette requête a été exécutée avec la fonction XMLExécuteXPath.
Versions 15 et supérieures
PHP Cette fonction est désormais disponible pour les sites PHP.
Nouveauté 15
PHP Cette fonction est désormais disponible pour les sites PHP.
PHP Cette fonction est désormais disponible pour les sites PHP.
Versions 17 et supérieures
iPhone/iPad Cette fonction est désormais disponible pour les applications iPhone/iPad.
Nouveauté 17
iPhone/iPad Cette fonction est désormais disponible pour les applications iPhone/iPad.
iPhone/iPad Cette fonction est désormais disponible pour les applications iPhone/iPad.
Versions 18 et supérieures
Universal Windows 10 App Cette fonction est désormais disponible en mode Windows Store apps.
Nouveauté 18
Universal Windows 10 App Cette fonction est désormais disponible en mode Windows Store apps.
Universal Windows 10 App Cette fonction est désormais disponible en mode Windows Store apps.
Versions 21 et supérieures
Universal Windows 10 App Cette fonction est désormais disponible en mode Universal Windows 10 App.
Nouveauté 21
Universal Windows 10 App Cette fonction est désormais disponible en mode Universal Windows 10 App.
Universal Windows 10 App Cette fonction est désormais disponible en mode Universal Windows 10 App.
Exemple
// Chargement du fichier XML
MonDoc est une chaîne
MonDoc = fChargeTexte("exemple.xml")
// Texte de la requête : Recherche de la balise Index
RequeteXPath est une chaîne = "Aide/Fonction/Index"
// Création du document
XMLDocument("Exemple", MonDoc)
SI ErreurDétectée = Vrai ALORS
        Erreur("le fichier n'est pas au format XML")
        RETOUR
FIN
b est un booléen
b = XMLExécuteXPath("Exemple", RequeteXPath)
// Est-ce une requête de calcul ?
SI b = Vrai ET XMLEnDehors("Exemple") = Vrai ALORS
         // Voilà le résultat du calcul
         Trace("XMLResultat = " + XMLRésultat("Exemple"))
FIN
// Est-ce une requête XPath de sélection ?
SI XMLTrouve("Exemple") = Vrai ALORS
        // Parcours de la sélection résultat
        TANTQUE XMLTrouve("Exemple") = Vrai
                Trace(XMLPosition("Exemple"))
                XMLSuivant("Exemple")
        FIN
        // Parcours terminé, on termine la requête
        XMLAnnuleRecherche("Exemple")
FIN
Syntaxe
<Résultat> = XMLRésultat(<Document XML>)
<Résultat> : Type correspondant au résultat de la requête XPath
Résultat de la requête de calcul XPath exécutée avec la fonction XMLExécuteXPath.
<Document XML> : Chaîne de caractères avec guillemets
Nom du document XML manipulé. Ce document a été créé avec la fonction XMLDocument.
Composante : wd240xml.dll
Version minimum requise
  • Version 9
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire