PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE

  • Rappel
  • Anciens navigateurs
WINDEV
WindowsLinuxUniversal Windows 10 AppJavaEtats et RequêtesCode Utilisateur (MCU)
WEBDEV
WindowsLinuxPHPWEBDEV - Code Navigateur
WINDEV Mobile
AndroidWidget AndroidiPhone/iPadWidget iOSApple WatchCatalystUniversal Windows 10 AppWindows Mobile
Autres
Procédures stockées
AJAXAppelAsynchroneEnCours (Fonction)
En anglais : AJAXAsynchronousCallPending
Permet de savoir si une procédure serveur appelée par la fonction AJAXExécuteAsynchrone est en cours d'exécution.
Exemple
// AJAX supporté sur le navigateur en cours ?
SI AJAXDisponible() = Vrai ALORS
// Exécution de la procédure serveur "MaProc"
// Dès que le résultat de la procédure serveur "MaProc"
// sera disponible,
// la procédure navigateur "ProcRésultat" sera exécutée
Res est un entier
Res = AJAXExécuteAsynchrone(MaProc, ProcRésultat)
// Les traitements suivants s'exécutent sans attendre le résultat
...
// État d'avancement de la procédure serveur "MaProc"
SI AJAXAppelAsynchroneEnCours(Res) = Vrai ALORS
// Annulation de l'exécution
// de la procédure navigateur "ProcRésultat"
// Le résultat de la procédure serveur "MaProc"
// ne pourra pas être traité
AJAXAnnuleAppelAsynchrone(Res)
FIN
SINON
// Traitements sans utilisation de AJAX
...
FIN
Syntaxe
<Résultat> = AJAXAppelAsynchroneEnCours(<Identifiant de la procédure serveur>)
<Résultat> : Booléen
  • Vrai si la procédure serveur spécifiée est en cours d'exécution,
  • Faux dans le cas contraire.
<Identifiant de la procédure serveur> : Entier
Identifiant de la procédure serveur à manipuler. Cet identifiant a été défini grâce à la fonction AJAXExécuteAsynchrone.
Remarques

Rappel

La fonction AJAXAnnuleAppelAsynchrone permet d'annuler l'exécution automatique de la procédure navigateur appelée par la fonction AJAXExécuteAsynchrone.

Anciens navigateurs

Les navigateurs anciens ne supportent pas la technologie AJAX (Internet Explorer 5.5 et supérieur, FireFox 1.0 et supérieur, Netscape 7 et supérieur, Opera 8 et supérieur, Safari 1.2 et supérieur, ...). La fonction AJAXDisponible permet de savoir si le navigateur en cours supporte la technologie AJAX. Si un traitement utilisant la technologie AJAX est exécuté sur un navigateur ne supportant pas cette technologie, le traitement s'exécute "comme si" il n'utilisait pas la technologie AJAX (rafraîchissement de la page entière par exemple).
Composante : WDJS.DLL
Version minimum requise
  • Version 10
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire