PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE

  • Rappel
  • Anciens navigateurs
WINDEV
WindowsLinuxUniversal Windows 10 AppJavaEtats et RequêtesCode Utilisateur (MCU)
WEBDEV
WindowsLinuxPHPWEBDEV - Code Navigateur
WINDEV Mobile
AndroidWidget AndroidiPhone/iPadWidget iOSApple WatchCatalystUniversal Windows 10 AppWindows Mobile
Autres
Procédures stockées
AJAXAnnuleAppelAsynchrone (Fonction)
En anglais : AJAXCancelAsynchronousCall
Annule l'exécution automatique de la procédure navigateur appelée par la fonction AJAXExécuteAsynchrone. La procédure serveur appelée par la fonction AJAXExécuteAsynchrone continuera de s'exécuter.
Rappel : La procédure navigateur permet de traiter le résultat renvoyé par la procédure serveur. Lors de l'utilisation de la fonction AJAXAnnuleAppelAsynchrone, le résultat de la procédure serveur ne sera donc pas traité
Exemple
// AJAX supporté sur le navigateur en cours ?
SI AJAXDisponible() = Vrai ALORS
// Exécution de la procédure serveur "MaProc"
// Dès que le résultat de la procédure serveur "MaProc"
// sera disponible,
// la procédure navigateur "ProcRésultat" sera exécutée
Res est un entier
Res = AJAXExécuteAsynchrone(MaProc, ProcRésultat)
// Les traitements suivants s'exécutent sans attendre le résultat
...
// État d'avancement de la procédure serveur "MaProc"
SI AJAXAppelAsynchroneEnCours(Res) = Vrai ALORS
// Annulation de l'exécution
// de la procédure navigateur "ProcRésultat"
// Le résultat de la procédure serveur "MaProc"
// ne pourra pas être traité
AJAXAnnuleAppelAsynchrone(Res)
FIN
SINON
// Traitements sans utilisation de AJAX
...
FIN
Syntaxe
AJAXAnnuleAppelAsynchrone(<Identifiant de la procédure serveur>)
<Identifiant de la procédure serveur> : Entier
Identifiant de la procédure serveur dont le résultat ne sera pas traité. Cet identifiant a été défini grâce à la fonction AJAXExécuteAsynchrone.
Remarques

Rappel

La fonction AJAXAppelAsynchroneEnCours permet de savoir si une procédure serveur appelée par la fonction AJAXExécuteAsynchrone est en cours d'exécution.

Anciens navigateurs

Les navigateurs anciens ne supportent pas la technologie AJAX (Internet Explorer 5.5 et supérieur, FireFox 1.0 et supérieur, Netscape 7 et supérieur, Opera 8 et supérieur, Safari 1.2 et supérieur, ...). La fonction AJAXDisponible permet de savoir si le navigateur en cours supporte la technologie AJAX. Si un traitement utilisant la technologie AJAX est exécuté sur un navigateur ne supportant pas cette technologie, le traitement s'exécute "comme si" il n'utilisait pas la technologie AJAX (rafraîchissement de la page entière par exemple).
Composante : WDJS.DLL
Version minimum requise
  • Version 10
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire