PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE

WINDEV
WindowsLinuxUniversal Windows 10 AppJavaEtats et RequêtesCode Utilisateur (MCU)
WEBDEV
WindowsLinuxPHPWEBDEV - Code Navigateur
WINDEV Mobile
AndroidWidget AndroidiPhone/iPadApple WatchUniversal Windows 10 AppWindows Mobile
Autres
Procédures stockées
L'instruction POUR TOUT permet de parcourir les options disponibles dans les combinaisons.
Remarque : Les instructions POUR TOUT, POUR TOUS, POUR CHAQUE sont acceptées. Dans cette documentation, seule l'instruction POUR TOUT est utilisée et peut être remplacée par POUR TOUS ou POUR CHAQUE.
Exemple
// Code de déclaration
// Déclarer une combinaison
TypeCombinaison est une Combinaison
CréationFic
LectureFic
EcritureFic
SuppressionFic
FIN
// Syntaxe 1 : Parcours des options de la combinaison
POUR TOUT eOption DE TypeCombinaison
Trace(eOption..Nom)
FIN
// Affectation de la variable
ActionFichier = LectureFic + EcritureFic

// Syntaxe 2 : Parcours des options actives
POUR TOUT eOption DE ActionFichier
Trace(eOption..Nom)
FIN
Syntaxe

Syntaxe simplifiée Masquer les détails

POUR TOUT <MonOption> DE <Combinaison>
    ...
FIN
<POUR TOUT> :
Signale le début du bloc d'instructions.
<MonOption> :
Variable de type Description d'Option correspondant à l'option de la combinaison. Il n'est pas nécessaire de déclarer cette variable.
<Combinaison> :
  • Combinaison contenant les valeurs à parcourir.
  • Variable de type Combinaison contenant les options à parcourir. Toutes les options (actives ou inactives) sont parcourues.

Parcours des options actives d'une variable de type Combinaison Masquer les détails

POUR TOUT <MonOption> DE <Combinaison>
    ...
FIN
<POUR TOUT> :
Signale le début du bloc d'instructions.
<MonOption> :
Variable de type Description d'Option correspondant à l'option de la combinaison. Il n'est pas nécessaire de déclarer cette variable.
<Combinaison> :
Variable de type Combinaison contenant les options à parcourir. Seules les options actives sont parcourues.
Version minimum requise
  • Version 23
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire