PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE

WINDEV
WindowsLinuxUniversal Windows 10 AppJavaEtats et RequêtesCode Utilisateur (MCU)
WEBDEV
WindowsLinuxPHPWEBDEV - Code Navigateur
WINDEV Mobile
AndroidWidget AndroidiPhone/iPadApple WatchUniversal Windows 10 AppWindows Mobile
Autres
Procédures stockées
L'instruction POUR TOUT permet de parcourir les valeurs disponibles dans les énumérations.
Remarque : Les instructions POUR TOUT, POUR TOUS, POUR CHAQUE sont acceptées. Dans cette documentation, seule l'instruction POUR TOUT est utilisée et peut être remplacée par POUR TOUS ou POUR CHAQUE.
Exemple
// Parcours des options d'une énumération
// ---------------------------------------
// Code de déclaration
// Déclarer une énumération
TypeAutomate est une Enumération
Marche
Arrêté
EnMaintenance
EnPanne
FIN
// Parcours des valeurs
POUR TOUT Option DE TypeAutomate
Trace(Option..Nom)
FIN
Syntaxe
POUR TOUT <MaValeur> DE <Enumération>
    ...
FIN
<POUR TOUT> :
Signale le début du bloc d'instructions.
<MaValeur> :
Variable de type Description de Valeur correspondant à la valeur de l'énumération. Il n'est pas nécessaire de déclarer cette variable.
<Enumération> :
Enumération contenant les valeurs à parcourir.
Version minimum requise
  • Version 23
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire