PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE

WINDEV
WindowsLinuxUniversal Windows 10 AppJavaEtats et RequêtesCode Utilisateur (MCU)
WEBDEV
WindowsLinuxPHPWEBDEV - Code Navigateur
WINDEV Mobile
AndroidWidget AndroidiPhone/iPadWidget IOSApple WatchMac CatalystUniversal Windows 10 App
Autres
Procédures stockées
Cherche les éléments d'un document HTML pour lesquels l'attribut "class" correspond à une valeur spécifique.
Exemple
d est un htmlDocument = HTMLOuvre("https://www.pcsoft.fr", depuisURL)
e est un tableau de htmlNoeud <- d.ChercheElémentParClasse("Red")
Syntaxe
<Résultat> = <Elément à manipuler>.ChercheElémentParClasse(<Attribut Class recherché>)
<Résultat> : Tableau
Tableau d'éléments de type htmlNoeud correspondant à la recherche.
<Elément à manipuler> : Variable de type htmlDocument
Nom de la variable de type htmlDocument dans laquelle la recherche doit être effectuée.
<Attribut Class recherché> : Chaîne de caractères
Valeur de l'attribut "Class" recherché.
Remarques
La fonction <Variable htmlDocument>.ChercheElémentParClasse respecte les règles de base de "sélection" des éléments HTML par leur(s) classe(s) :
  • recherche des différentes classes séparées par des espaces, toutes les classes demandées doivent être présentes (recherche "ET").
  • recherche sensible à la casse (de manière générale, les classes sont toujours en minuscules).
  • recherche en ignorant les doublons.
Exemple :
d est un htmlDocument
 
d.html.body.span[1]:id = "1"
d.html.body.span[1]:class = "ab"
 
d.html.body.span[2]:id = "2"
d.html.body.span[2]:class = "ab cd"
 
d.html.body.span[3]:id = "3"
d.html.body.span[3]:class = "cd"
 
d.html.body.span[4]:id = "4"
d.html.body.span[4]:class = "ab cd ab"
 
t est un tableau de htmlNoeud
 
Trace("-- ab")
t = d.ChercheElémentParClasse("ab")
POUR TOUT x DE t
Trace(x:id)
FIN
 
Trace("-- cd")
t = d.ChercheElémentParClasse("cd")
POUR TOUT x DE t
Trace(x:id)
FIN
 
Trace("-- ab cd")
t = d.HTMLChercheElémentParClasse("ab cd")
POUR TOUT x DE t
Trace(x:id)
FIN
Composante : wd270html.dll
Version minimum requise
  • Version 26
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire