PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE

WINDEV
WindowsLinuxUniversal Windows 10 AppJavaEtats et RequêtesCode Utilisateur (MCU)
WEBDEV
WindowsLinuxPHPWEBDEV - Code Navigateur
WINDEV Mobile
AndroidWidget AndroidiPhone/iPadWidget iOSApple WatchCatalystUniversal Windows 10 AppWindows Mobile
Autres
Procédures stockées
Procédure WLangage appelée par la fonction AppleSignIn
Procédure (également appelée "Callback") appelée par la fonction AppleSignIn lorsque le résultat de l'authentification Apple est obtenue. Cette procédure peut être une procédure locale, globale, interne ou une procédure lambda.
Exemple
PROCÉDURE INTERNE auth(c est un AppleID)
SI c.Valide = Faux ALORS
SI ErreurInfo(errCode) = 600062 ALORS
LIB_Auth = "Vous avez annulé l'authentification."
SINON
LIB_Auth = "Erreur pendant l'authentification" + RC + ErreurInfo()
FIN
SINON
LIB_Auth = "Bonjour " + c.Utilisateur + RC
LIB_Auth += c.Nom + " " + c.Prénom + RC
LIB_Auth += c.Email + RC
LIB_Auth += c.Source + RC
FIN
FIN
 
AppleSignIn(auth)
Syntaxe
AppleSignIn_Callback(<Authentification>)
<Authentification> : Variable de type AppleID
Variable de type AppleID correspondant au justificatif d'identité résultant d'une authentification réussie de l'authentification Apple.
Version minimum requise
  • Version 25
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire