PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE

Nouveauté WINDEV Mobile 25 !
  • Conditions nécessaires
  • Créer un champ Bouton Apple Sign In au bon look
WINDEV
WindowsLinuxUniversal Windows 10 AppJavaEtats et RequêtesCode Utilisateur (MCU)
WEBDEV
WindowsLinuxPHPWEBDEV - Code Navigateur
WINDEV Mobile
AndroidWidget AndroidiPhone/iPadWidget iOSApple WatchCatalystUniversal Windows 10 AppWindows Mobile
Autres
Procédures stockées
AppleSignIn (Fonction)
En anglais : AppleSignIn
Permet d'effectuer une authentification par "Connexion avec Apple" sur le matériel iOS 13 et plus. Une fenêtre externe permet à l'utilisateur de s'authentifier avec ses identifiants AppleID.
Exemple
PROCÉDURE INTERNE auth(c est un AppleID)
SI c.Valide = Faux ALORS
SI ErreurInfo(errCode) = 600062 ALORS
LIB_Auth = "Vous avez annulé l'authentification."
SINON
LIB_Auth = "Erreur pendant l'authentification" + RC + ErreurInfo()
FIN
SINON
LIB_Auth = "Bonjour " + c..Utilisateur + RC
LIB_Auth += c..Nom + " " + c..Prénom + RC
LIB_Auth += c..Email + RC
LIB_Auth += c..Source + RC
FIN
FIN
 
AppleSignIn(auth)
Syntaxe
AppleSignIn(<Procédure WLangage>)
<Procédure WLangage> : Nom de procédure
Nom de la procédure WLangage (également nommée "callback") appelée lorsque le résultat de l'authentification est obtenu. Pour plus de détails sur cette procédure, consultez Paramètres de la procédure utilisée par la fonction AppleSignIn.
Remarques

Conditions nécessaires

Cette fonction nécessite :
  • une version de iOS supérieure ou égale à 13 ou une version de macOS supérieure ou égale à 10.15.
  • l'activation de "Sign In" dans le "Provisioning profile" de votre application.

Créer un champ Bouton Apple Sign In au bon look

Pour créer un champ Bouton proposant une authentification Apple avec le look correspondant :
  1. Créez un champ Bouton dans votre fenêtre : sous le volet "Création", dans le groupe "Champs usuels", cliquez sur "Bouton".
  2. Affichez si nécessaire le volet "Modifieur" : sous le volet "Accueil", dans le groupe "Environnement", déroulez "Volets" et sélectionnez "Modifieur".
  3. Sélectionnez le champ Bouton : dans le volet "Modifieur" les caractéristiques du champ sont affichées.
  4. Dans la zone "Détails" du volet "Modifieur" :
    • Pour l'option "Apple Sign In - Mode", sélectionnez "Enregistrement (Sign In)".
    • Pour l'option "Apple Sign In - Style", sélectionnez le style voulu pour votre bouton ("Selon thème", "Noir", "Blanc", "Blanc avec bordure").
Il ne reste plus qu'à écrire le code WLangage du champ pour réaliser l'authentification "Apple Sign In".
Version minimum requise
  • Version 25
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire