PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE

Nouveauté WINDEV Mobile 25 !
WINDEV
WindowsLinuxUniversal Windows 10 AppJavaEtats et RequêtesCode Utilisateur (MCU)
WEBDEV
WindowsLinuxPHPWEBDEV - Code Navigateur
WINDEV Mobile
AndroidWidget AndroidiPhone/iPadWidget iOSApple WatchCatalystUniversal Windows 10 AppWindows Mobile
Autres
Procédures stockées
Récupère la liste des paramètres OAuth définis pour le groupware utilisateur, c'est-à-dire la liste des providers (Google, Facebook, ...) auxquels il est possible de se connecter via le groupware utilisateur. Ces paramètres ont été définis via le site d'administration du groupware utilisateur.
Exemple
tabOAuthParam est un tableau de gpwOAuthParamètres
tabOAuthParam = gpwListeOAuthParamètres()
SI ErreurDétectée ALORS
Erreur(ErreurInfo())
RETOUR
FIN
 
Paramètres est un gpwOAuthParamètres = tabOAuthParam[1]
sCode est une chaîne = gpwAuthLogin(Paramètres)
SI ErreurDétectée ALORS
Erreur(ErreurInfo())
RETOUR
FIN
 
Utilisateur est un gpwUtilisateur
sToken est une chaîne
(Utilisateur, sToken) = gpwConnecteDistant(Paramètres, sCode)
SI ErreurDétectée ALORS
Erreur(ErreurInfo())
RETOUR
FIN
Syntaxe
<Résultat> = gpwListeOAuthParamètres()
<Résultat> : Tableau de variables de type gpwOAuthParamètres
Tableau de variables de type gpwOauthParamètres correspondant à la description des paramètres OAuth.
Classification Métier / UI : Code métier
Composante : wd250android.jar
Version minimum requise
  • Version 25
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire