PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE


  • Sélection dans un champ Traitement de texte
WINDEV
WindowsLinuxUniversal Windows 10 AppJavaEtats et RequêtesCode Utilisateur (MCU)
WEBDEV
WindowsLinuxPHPWEBDEV - Code Navigateur
WINDEV Mobile
AndroidWidget AndroidiPhone/iPadWidget IOSApple WatchMac CatalystUniversal Windows 10 App
Autres
Procédures stockées
La propriété Sélection permet d'obtenir les caractéristiques de la sélection (ou du curseur) :
  • WINDEV dans un champ Traitement de texte.
    Remarque : Cette sélection est située dans la partie en cours d'édition dans le champ (corps, entête ou pied de page).
  • Versions 23 et supérieures
    WINDEV dans un champ Tableur.
    Nouveauté 23
    WINDEV dans un champ Tableur.
    WINDEV dans un champ Tableur.
  • Versions 26 et supérieures
    WINDEV dans un champ Editeur HTML.
    Nouveauté 26
    WINDEV dans un champ Editeur HTML.
    WINDEV dans un champ Editeur HTML.
  • Versions 27 et supérieures
    dans un champ Editeur de diagrammes.
    Nouveauté 27
    dans un champ Editeur de diagrammes.
    dans un champ Editeur de diagrammes.
Exemple
WINDEV
// Récupération du fragment sélectionné par l'utilisateur
MaSélection est un docFragment = TT_Doc.Sélection.Fragment
// Mise en gras de la sélection de l'utilisateur
MaSélection.MiseEnForme.PoliceGras = Vrai
// Récupération de la première section du texte sélectionné par l'utilisateur
MaSection1 est un docSection = TT_Doc.Sélection.Section[1]
Versions 27 et supérieures
// Obtenir la sélection dans un champ Editeur de diagrammes
MaSélection est un diagSélection <- EDIAG_MonDiagramme.Sélection
SI MaSélection.Forme.Occurrence > 0 ALORS
// Obtenir les formes
POUR TOUT stForme DE MaSélection.Forme
LIB_INFO_SELECTION = "Sélection de " + stForme.Nom +
" [ " + stForme.X + ", " + stForme.Y + " - " + stForme.Largeur +
"x" + stForme.Hauteur + " ]"
FIN
SINON
LIB_INFO_SELECTION = "Cliquez sur une forme dans le diagramme pour connaître la sélection"
FIN
Nouveauté 27
// Obtenir la sélection dans un champ Editeur de diagrammes
MaSélection est un diagSélection <- EDIAG_MonDiagramme.Sélection
SI MaSélection.Forme.Occurrence > 0 ALORS
// Obtenir les formes
POUR TOUT stForme DE MaSélection.Forme
LIB_INFO_SELECTION = "Sélection de " + stForme.Nom +
" [ " + stForme.X + ", " + stForme.Y + " - " + stForme.Largeur +
"x" + stForme.Hauteur + " ]"
FIN
SINON
LIB_INFO_SELECTION = "Cliquez sur une forme dans le diagramme pour connaître la sélection"
FIN
// Obtenir la sélection dans un champ Editeur de diagrammes
MaSélection est un diagSélection <- EDIAG_MonDiagramme.Sélection
SI MaSélection.Forme.Occurrence > 0 ALORS
// Obtenir les formes
POUR TOUT stForme DE MaSélection.Forme
LIB_INFO_SELECTION = "Sélection de " + stForme.Nom +
" [ " + stForme.X + ", " + stForme.Y + " - " + stForme.Largeur +
"x" + stForme.Hauteur + " ]"
FIN
SINON
LIB_INFO_SELECTION = "Cliquez sur une forme dans le diagramme pour connaître la sélection"
FIN
Syntaxe
WINDEV

Récupérer les propriétés de la sélection dans un champ Traitement de texte Masquer les détails

<Résultat> = <Champ Traitement de texte>.Sélection.<Propriété>
<Résultat> : Type correspondant à la propriété utilisée
Résultat attendu (voir "Remarques").
<Champ Traitement de texte> : Nom de champ
Nom du champ Traitement de texte.
<Propriété> :
Propriété à utiliser sur la sélection (voir Remarques).
Versions 23 et supérieures
WINDEV

Récupérer les propriétés de la sélection dans un champ Tableur Masquer les détails

<Résultat> = <Champ Tableur>.Sélection
<Résultat> : Variable de type tblrSélection
Variable de type tblrSélection décrivant la sélection.
<Champ Tableur> : Nom de champ
Nom du champ Tableur.
Nouveauté 23
WINDEV

Récupérer les propriétés de la sélection dans un champ Tableur Masquer les détails

<Résultat> = <Champ Tableur>.Sélection
<Résultat> : Variable de type tblrSélection
Variable de type tblrSélection décrivant la sélection.
<Champ Tableur> : Nom de champ
Nom du champ Tableur.
WINDEV

Récupérer les propriétés de la sélection dans un champ Tableur Masquer les détails

<Résultat> = <Champ Tableur>.Sélection
<Résultat> : Variable de type tblrSélection
Variable de type tblrSélection décrivant la sélection.
<Champ Tableur> : Nom de champ
Nom du champ Tableur.
Versions 26 et supérieures
WINDEV

Récupérer les propriétés de la sélection dans un champ Editeur HTML Masquer les détails

<Résultat> = <Champ Editeur HTML>.Sélection
<Résultat> : Variable de type edtHTMLSélection
Variable de type edtHTMLSélection décrivant la sélection.
<Champ Editeur HTML> : Nom de champ
Nom du champ Editeur HTML.
Nouveauté 26
WINDEV

Récupérer les propriétés de la sélection dans un champ Editeur HTML Masquer les détails

<Résultat> = <Champ Editeur HTML>.Sélection
<Résultat> : Variable de type edtHTMLSélection
Variable de type edtHTMLSélection décrivant la sélection.
<Champ Editeur HTML> : Nom de champ
Nom du champ Editeur HTML.
WINDEV

Récupérer les propriétés de la sélection dans un champ Editeur HTML Masquer les détails

<Résultat> = <Champ Editeur HTML>.Sélection
<Résultat> : Variable de type edtHTMLSélection
Variable de type edtHTMLSélection décrivant la sélection.
<Champ Editeur HTML> : Nom de champ
Nom du champ Editeur HTML.
Versions 27 et supérieures

Récupérer les propriétés de la sélection dans un champ Editeur de diagrammes Masquer les détails

<Résultat> = <Champ Editeur de diagrammes>.Sélection
<Résultat> : Variable de type diagSélection
Variable de type diagSélection décrivant la sélection.
<Champ Editeur de diagrammes> : Nom de champ
Nom du champ Editeur de diagrammes.
Nouveauté 27

Récupérer les propriétés de la sélection dans un champ Editeur de diagrammes Masquer les détails

<Résultat> = <Champ Editeur de diagrammes>.Sélection
<Résultat> : Variable de type diagSélection
Variable de type diagSélection décrivant la sélection.
<Champ Editeur de diagrammes> : Nom de champ
Nom du champ Editeur de diagrammes.

Récupérer les propriétés de la sélection dans un champ Editeur de diagrammes Masquer les détails

<Résultat> = <Champ Editeur de diagrammes>.Sélection
<Résultat> : Variable de type diagSélection
Variable de type diagSélection décrivant la sélection.
<Champ Editeur de diagrammes> : Nom de champ
Nom du champ Editeur de diagrammes.
Remarques
WINDEV

Sélection dans un champ Traitement de texte

PropriétéExplications
Fragment<Résultat> correspond à une variable de type docFragment contenant les caractéristiques du fragment sélectionné.
Exemple : <Résultat> = <Champ Traitement de texte>.Sélection.Fragment
Section[X]Permet de récupérer la section associée à la sélection.
  • X correspond au numéro de la section à récupérer.
  • <Résultat> correspond à une variable de type docSection contenant les caractéristiques de la section associée à la sélection.
Exemple : <Résultat> = <Champ Traitement de texte>.Sélection.Section[1]
Version minimum requise
  • Version 22
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire