PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEV, WEBDEV ET WINDEV MOBILE

WINDEV
WindowsLinuxUniversal Windows 10 AppJavaEtats et RequêtesCode Utilisateur (MCU)
WEBDEV
WindowsLinuxPHPWEBDEV - Code Navigateur
WINDEV Mobile
AndroidWidget AndroidiPhone/iPadApple WatchUniversal Windows 10 AppWindows Mobile
Autres
Procédures stockées
Recherche une chaîne de caractère dans l’ensemble d’un document de type Traitement de texte. Attention : Cette documentation présente les dernières fonctionnalités du champ Traitement de texte. Assurez-vous d'être à jour de tous les modules nécessaires.
Exemple
tabFragments est tableau de docFragments = DocRecherche(TT_MonDocument, "%NomClient%")
// Remplacement de tous les "%NomClient%" par le nom du client
POUR TOUT f DE tabFragments
f..Texte = Client.Nom
FIN
// Recherche du mot "BEAUGRAND" dans le texte
// Sélectionne uniquement le premier trouvé pour changer sa couleur
tabFragments est tableau de docFragments = DocRecherche(TT_SansNom1, "BEAUGRAND")

SI tabFragments..Occurrence >= 1 ALORS
// Positionnement du curseur au début du premier mot trouvé
TT_SansNom1..Curseur = tabFragments[1]..PositionDébut
// Calcul de la longueur de la sélection
TT_SansNom1..LongueurSélection = abFragments[1]..PositionFin - abFragments[1]..PositionDébut+1
// Modification de la couleur du texte
abFragments[1]..Style..CouleurTexte = RougePastel
SORTIR
FIN
// Recherche du mot "BEAUGRAND" dans le texte
// Sélectionne uniquement le premier trouvé pour changer sa couleur
tabFragments est tableau de docFragments = DocRecherche(TT_SansNom1, "BEAUGRAND")

SI tabFragments..Occurrence >= 1 ALORS
// Positionnement du curseur au début du premier mot trouvé
TT_SansNom1..Curseur = tabFragments[1]..PositionDébut
// Calcul de la longueur de la sélection
TT_SansNom1..LongueurSélection = tabFragments[1]..PositionFin - tabFragments[1]..PositionDébut+1
// Modification de la couleur du texte
tabFragments[1]..MiseEnForme..CouleurTexte = RougePastel
SORTIR
FIN
Syntaxe
<Résultat> = DocRecherche(<Document> , <Texte à rechercher> [, <Options>])
<Résultat> : Tableau de variables de type docFragment
Tableau de variables de type docFragment correspondant à l'ensemble des fragments du document dans lequel le texte recherché a été trouvé.
<Document> : Variable de type Document ou chaîne de caractères (avec ou sans guillemets)
Document à manipuler. Ce document correspond :
  • WINDEV au nom d'un champ Traitement de texte.
  • à une variable de type Document.
<Texte à rechercher> : Chaîne de caractères (avec guillemets)
Texte à rechercher dans le document.
<Options> : Constante (ou combinaison de constantes) optionnelle
Options de recherche :
MotCompletRecherche le mot complet (entouré par des caractères de ponctuation ou des espaces).
SansCasseRecherche sans tenir compte de la casse (majuscules/minuscules) et des accents.

Par défaut, la recherche est sensible à la casse : le texte recherché doit avoir la même casse que le texte à trouver. Pour effectuer une recherche ne tenant pas compte de la casse, utilisez la constante SansCasse.
Classification Métier / IHM : Code IHM
Composante : wd240mdl.dll
Version minimum requise
  • Version 22
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire