PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE

WINDEV
WindowsLinuxUniversal Windows 10 AppJavaEtats et RequêtesCode Utilisateur (MCU)
WEBDEV
WindowsLinuxPHPWEBDEV - Code Navigateur
WINDEV Mobile
AndroidWidget AndroidiPhone/iPadApple WatchUniversal Windows 10 AppWindows Mobile
Autres
Procédures stockées
Supprime toutes les formules ajoutées avec la fonction TableFormuleAjoute.
Exemple
TableFormuleSupprimeTout(TABLE_MaTable)
nLigne est entier
nLigne = TableFormuleAjoute(TABLE_MaTable.COL_Num, "Moyenne positive", ProcInit, ProcAjout, ProcFin)
// Changement de la couleur de fond de la ligne du calcul personnalisé
COL_Num[nLigne]..CouleurFond = RougeClair

nCompteur est entier
PROCÉDURE INTERNE ProcInit()
nCompteur = 0
RENVOYER 0
FIN

PROCÉDURE INTERNE ProcAjout(Accumulateur, ValeurCol)
// Ignore les négatifs ou NULL
SI (ValeurCol <= 0) RENVOYER Accumulateur
nCompteur++
RENVOYER Accumulateur + ValeurCol
FIN
PROCÉDURE INTERNE ProcFin(Accumulateur)
SI nCompteur = 0 ALORS RENVOYER 0
// Calcul de la moyenne
RENVOYER  Accumulateur/nCompteur
FIN
Syntaxe
TableFormuleSupprimeTout(<Champ Table>)
<Champ Table> : Nom de champ
Nom du champ à manipuler. Ce champ peut correspondre à :
  • un champ Table.
  • un champ Table hiérarchique.
Si ce paramètre correspond à une chaîne vide (""), le champ manipulé est le champ auquel appartient l'événement en cours.
Remarques
Les calculs prédéfinis (total, moyenne, comptage, min, max) ne sont pas affectés.
Composante : wd240obj.dll
Version minimum requise
  • Version 22
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire