PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE

  • Présentation
  • Manipulation dynamique des fichiers XLS et XLSX
WINDEV
WindowsLinuxUniversal Windows 10 AppJavaEtats et RequêtesCode Utilisateur (MCU)
WEBDEV
WindowsLinuxPHPWEBDEV - Code Navigateur
WINDEV Mobile
AndroidWidget AndroidiPhone/iPadWidget IOSApple WatchMac CatalystUniversal Windows 10 App
Autres
Procédures stockées
Présentation
En syntaxe préfixée, WINDEV et WEBDEV permettent de manipuler les fichiers Excel via la Manipulation dynamique des feuilles XLS et XLSX.
Cette méthode utilise différents types de variables ainsi que des fonctions WLangage. Cette méthode permet de gérer les fichiers Excel (fichiers XLS ou XLSX) en lecture et en écriture.
Manipulation dynamique des fichiers XLS et XLSX
Pour manipuler les fichiers XLS et XLSX, le WLangage met à votre disposition :
  • différents types de variables. Ces types de variables permettent de manipuler un document XLS, une ligne ou une colonne XLS, une cellule XLS.
  • différentes fonctions WLangage manipulant les différents types de données.
Pour manipuler les fichiers XLS et XLSX :
  1. Déclarez une variable de type xlsDocument. Ce type de variable permet de décrire et de modifier un document Excel.
  2. Ouvrez si nécessaire le fichier XLS (fonction xlsOuvre) et associez-le à la variable de type xlsDocument.
  3. Vous pouvez manipuler les différents éléments du document Excel :
    • soit avec les fonctions WLangage.
    • soit avec les propriétés du type xlsDocument.
Exemple :
MonFicXLS est un xlsDocument
UnFichier est une chaîne
UnFichier = fRepExe + "\Suivi d'affaires1.xls"

MonFicXLS = xlsOuvre(UnFichier, xlsEcriture)
SI ErreurDétectée = Faux ALORS
Azz est un entier = MonFicXLS..Feuille
Info("Feuille en cours dans le fichier Excel : " + Azz)
// Changement de feuille
SI MonFicXLS..Feuille = 2 ALORS
Info("La feuille courante a été modifiée.")
// Lecture d'une cellule pour test
Info(xlsDonnée(IDFicXLS, 11, 2))
SINON
Erreur("Le fichier sélectionné ne comporte pas de seconde feuille !")
FIN
SINON
Erreur("Attention ! le fichier est déjà ouvert sur un poste de travail !")
FIN
Remarques :
  • Si le fichier Excel est ouvert en mode lecture/écriture (constante xlsEcriture), le fichier est ouvert et bloqué jusqu'à sa fermeture. Pour sauvegarder les modifications réalisées, utilisez la fonction <Variable xlsDocument>.Sauve.
  • Les fonctions XLS ne nécessitent pas l'installation du logiciel "Microsoft Excel" sur le poste des utilisateurs.
  • Les fichiers XLS et les fichiers spécifiques à Office 2007 (fichiers .xlsx) sont gérés.
Version minimum requise
  • Version 24
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire