PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE

WINDEV
WindowsLinuxUniversal Windows 10 AppJavaEtats et RequêtesCode Utilisateur (MCU)
WEBDEV
WindowsLinuxPHPWEBDEV - Code Navigateur
WINDEV Mobile
AndroidWidget AndroidiPhone/iPadWidget iOSApple WatchCatalystUniversal Windows 10 AppWindows Mobile
Autres
Procédures stockées
Vérifie l'existence et la validité du mot de passe d'un utilisateur du groupware utilisateur.
Versions 24 et supérieures
WEBDEV - Code ServeurLinux Cette fonction est désormais disponible pour les sites WEBDEV sous Linux.
Nouveauté 24
WEBDEV - Code ServeurLinux Cette fonction est désormais disponible pour les sites WEBDEV sous Linux.
WEBDEV - Code ServeurLinux Cette fonction est désormais disponible pour les sites WEBDEV sous Linux.
Exemple
nRes est un entier = gpwVérifieUtilisateur(Login, MotPasse)
// Si le login a échoué
SI nRes <> gpwOk ALORS
       SELON nRes
               CAS gpwErreur : Erreur("Erreur à l'initialisation du groupware.")
               CAS gpwUtilisateurInconnu : Erreur("Utilisateur inconnu.")
               CAS gpwMotPasseInvalide : Erreur("Mot de passe invalide.")
       FIN
       FinProgramme()
FIN
Syntaxe
<Résultat> = gpwVérifieUtilisateur(<Login> , <Mot de passe>)
<Résultat> : Entier
Résultat de la vérification :
gpwErreurUne erreur est survenue. Pour plus de détails sur l'erreur, utilisez la fonction ErreurInfo.
gpwMotPasseInvalideLe mot de passe de l'utilisateur n'est pas valide. Il ne correspond pas au mot de passe de l'utilisateur décrit dans la base de données du groupware utilisateur.
gpwOKL'utilisateur est connecté.
gpwUtilisateurInconnuL'utilisateur est inconnu : il n'est pas présent dans la base de données du groupware utilisateur.
<Login> : Chaîne de caractères (avec guillemets)
Login de l'utilisateur.
<Mot de passe> : Chaîne de caractères (avec guillemets)
Mot de passe associé au login de l'utilisateur.
Composante : wd250gpu.dll
Version minimum requise
  • Version 19
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire