PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE

PV

WINDEV
WindowsLinuxUniversal Windows 10 AppJavaEtats et RequêtesCode Utilisateur (MCU)
WEBDEV
WindowsLinuxPHPWEBDEV - Code Navigateur
WINDEV Mobile
AndroidWidget AndroidiPhone/iPadWidget IOSApple WatchMac CatalystUniversal Windows 10 App
Autres
Procédures stockées
Connecte un utilisateur au groupware utilisateur.
Exemple
WEBDEV - Code Serveur
// Connexion de l'utilisateur
nValeurRenvoyee est un entier = gpwConnecteUtilisateur(SAI_Login, SAI_MotPasse)
 
// Si échec de connexion
SI nValeurRenvoyee <> gpwOk ALORS
SELON nValeurRenvoyee
CAS gpwErreur : Erreur("Connexion impossible.")
CAS gpwUtilisateurInconnu, gpwMotPasseInvalide :
Erreur("Utilisateur ou mot de passe incorrect.")
FIN
SINON
// Connexion en administrateur
SI gpwRecupInfoUtilisateur(gpwInfoSuperviseur) ALORS
// Ouvre la page d'administration du groupware
gpwOuvreConfiguration()
// Actualise la page
SINON
PageUtilise(MaPage..Nom)
FIN
FIN
Syntaxe

Connecter un utilisateur au groupware utilisateur Masquer les détails

<Résultat> = gpwConnecteUtilisateur(<Login> , <Mot de passe>)
<Résultat> : Constante de type Entier
Résultat de la connexion :
gpwErreurUne erreur est survenue. Pour plus de détails sur l'erreur, utilisez la fonction ErreurInfo.
gpwMotPasseInvalideLe mot de passe de l'utilisateur est inconnu.
gpwOKLa connexion de l'utilisateur a été réalisée.
gpwUtilisateurInconnuL'utilisateur est inconnu : il n'est pas présent dans la base de données du groupware utilisateur.
<Login> : Chaîne de caractères
Login de l'utilisateur.
<Mot de passe> : Chaîne de caractères
Mot de passe associé au login de l'utilisateur.

Connecter un utilisateur identifié par son adresse email au groupware utilisateur Masquer les détails

<Résultat> = gpwConnecteUtilisateur(<Email de l'utilisateur>)
<Résultat> : Constante de type Entier
Résultat de la connexion :
gpwErreurUne erreur est survenue. Pour plus de détails sur l'erreur, utilisez la fonction ErreurInfo.
gpwMotPasseInvalideLe mot de passe de l'utilisateur est inconnu.
gpwOKLa connexion de l'utilisateur a été réalisée.
gpwUtilisateurInconnuL'utilisateur est inconnu : il n'est pas présent dans la base de données du groupware utilisateur.
<Email de l'utilisateur> : Chaîne de caractères
Email de l'utilisateur récupéré lors d'une authentification via OpenID (propriété Email de la variable OpenIDIdentité).
Classification Métier / UI : Code neutre
Composante : wd280gpu.dll
Version minimum requise
  • Version 19
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire