PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE

WINDEV
WindowsLinuxUniversal Windows 10 AppJavaEtats et RequêtesCode Utilisateur (MCU)
WEBDEV
WindowsLinuxPHPWEBDEV - Code Navigateur
WINDEV Mobile
AndroidWidget AndroidiPhone/iPadWidget IOSApple WatchMac CatalystUniversal Windows 10 App
Autres
Procédures stockées
Récupère les caractéristiques d'un utilisateur du groupware utilisateur.
Versions 24 et supérieures
WEBDEV - Code ServeurLinux Cette fonction est désormais disponible pour les sites WEBDEV sous Linux.
WINDEVLinux Cette fonction est désormais disponible pour les applications WINDEV sous Linux.
WINDEVWindows Cette fonction est désormais disponible pour les applications WINDEV sous Windows.
Nouveauté 24
WEBDEV - Code ServeurLinux Cette fonction est désormais disponible pour les sites WEBDEV sous Linux.
WINDEVLinux Cette fonction est désormais disponible pour les applications WINDEV sous Linux.
WINDEVWindows Cette fonction est désormais disponible pour les applications WINDEV sous Windows.
WEBDEV - Code ServeurLinux Cette fonction est désormais disponible pour les sites WEBDEV sous Linux.
WINDEVLinux Cette fonction est désormais disponible pour les applications WINDEV sous Linux.
WINDEVWindows Cette fonction est désormais disponible pour les applications WINDEV sous Windows.
Exemple
// Recherche de l'utilisateur
clUtilisateur est un gpwUtilisateur = gpwRechercheUtilisateur(gsEmail)
// Utilisateur non trouvé
SI ErreurDétectée ALORS
RETOUR
FIN
 
// Modification du mot de passe
clUtilisateur.MotDePasse = SAI_MotPasseNouveau
SI gpwModifieUtilisateur(clUtilisateur) = Faux ALORS
Info("Impossible de modifier l'utilisateur.")
RETOUR
FIN
Syntaxe
<Résultat> = gpwRechercheUtilisateur(<Identifiant>)
<Résultat> : Variable de type gpwUtilisateur
Nom de la variable de type gpwUtilisateur contenant les caractéristiques de l'utilisateur recherché.
<Identifiant> : Chaîne de caractères
Login ou email de l'utilisateur. Si une adresse email est spécifiée, la recherche sera effectuée dans la propriété Email de la variable gpwUtilisateur, dans le cas contraire, la recherche sera effectuée dans la propriété Login de la variable gpwUtilisateur.
Composante : wd270gpu.dll
Version minimum requise
  • Version 19
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire