PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE

  • Suppression d'agenda
WINDEV
WindowsLinuxUniversal Windows 10 AppJavaEtats et RequêtesCode Utilisateur (MCU)
WEBDEV
WindowsLinuxPHPWEBDEV - Code Navigateur
WINDEV Mobile
AndroidWidget AndroidiPhone/iPadWidget iOSApple WatchCatalystUniversal Windows 10 AppWindows Mobile
Autres
Procédures stockées
Supprime des données sur le serveur Google. Les données créées ou mises à jour sont contenues dans une variable correspondant au service manipulé :
  • Variable de type gglAgenda pour supprimer un agenda.
  • Variable de type gglContact pour supprimer un contact.
  • Variable de type gglGroupeContact pour supprimer un groupe de contacts.
Exemple
// Connexion
Cnx est un gglConnexion
...
SI GglConnecte(Cnx) = Faux ALORS
Erreur(ErreurInfo())
FIN
 
// Récupération de l'agenda "Travail"
tabAgenda est un tableau de 0 gglAgenda
tabAgenda = GglListeAgenda(Cnx, gglUtilisateur)
// Affichage du titre de chaque agenda
Agenda est un gglAgenda
POUR TOUT Agenda DE tabAgenda
SI Agenda.Titre = "TRAVAIL" ALORS
  // Suppression de l'agenda
  GglSupprime(Cnx, Agenda)
FIN
FIN
Syntaxe
<Résultat> = GglSupprime(<Connexion Google> , <Elément Google>)
<Résultat> : Booléen
  • Vrai si la suppression a été réalisée,
  • Faux en cas d'erreur. Pour plus de détails sur l'erreur, utilisez la fonction ErreurInfo.
<Connexion Google> : Variable de type gglConnexion
Nom de la variable de type gglConnexion à utiliser. Cette connexion a été validée avec la fonction GglConnecte.
<Elément Google> : Variable correspondant au type à supprimer
Elément à supprimer. Ce paramètre peut correspondre à :
  • Nom de la variable de type gglAgenda correspondant à l'agenda à supprimer.
  • Nom de la variable gglContact correspondant au contact à supprimer.
  • Nom de la variable de type gglGroupeContact correspondant au groupe de contacts à supprimer.
Remarques

Suppression d'agenda

Pour supprimer un agenda, cet agenda doit avoir été récupéré auparavant avec la fonction GglListeAgenda avec la constante gglUtilisateur. Dans le cas contraire, le serveur renvoie une erreur "InternalServerError".
Composante : wd260ggl.dll
Version minimum requise
  • Version 14
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire