PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE

  • Cas particuliers
  • Cas d'erreurs possibles :
  • Limite
WINDEV
WindowsLinuxUniversal Windows 10 AppJavaEtats et RequêtesCode Utilisateur (MCU)
WEBDEV
WindowsLinuxPHPWEBDEV - Code Navigateur
WINDEV Mobile
AndroidWidget AndroidiPhone/iPadWidget iOSApple WatchCatalystUniversal Windows 10 AppWindows Mobile
Autres
Procédures stockées
Récupère la liste des agendas Google associés au compte Google spécifié. Cette fonction utilise le service Agenda Google Calendar.
// Connexion
Cnx est un gglConnexion
...
SI GglConnecte(Cnx) = Faux ALORS
Erreur(ErreurInfo())
RETOUR
FIN
tabAgendas est un tableau de gglAgenda
tabAgendas = GglListeAgenda(Cnx, gglTous)
// Affichage du titre de chaque agenda
Agenda est un gglAgenda
POUR TOUT Agenda DE tabAgendas
Trace(Agenda.Titre)
FIN
Syntaxe
<Résultat> = GglListeAgenda(<Connexion Google> [, <Filtre>])
<Résultat> : Tableau de variables de type gglAgenda
Liste des agendas Google du compte spécifié.
<Connexion Google> : Variable de type gglConnexion
Nom de la variable de type gglConnexion à utiliser. Cette connexion a été validée avec la fonction GglConnecte.
<Filtre> : Constante de type Entier optionnelle
Indique le type d'agenda à lister :
gglTous
(Valeur par défaut)
Liste tous les agendas souscrits (partagés) et créés par l'utilisateur en cours.
gglUtilisateurListe uniquement les agendas créés par l'utilisateur en cours.
Remarques

Cas particuliers

Les agendas renvoyés ne contiennent pas leurs événements. Pour obtenir les événements des agendas, utilisez les fonctions GglRemplitAgenda ou GglRemplitAgendaParRequête.
Pour obtenir l'agenda avec les événements associés, utilisez la fonction GglRécupèreAgenda.

Cas d'erreurs possibles :

  • La connexion Internet n'est pas valide.
  • L'authentification n'a pas pu être réalisée correctement.
  • La réponse XML du serveur n'est pas lisible.
Pour savoir si une erreur est survenue, utilisez la variable ErreurDétectée.

Limite

Seuls les 100 premiers agendas sont renvoyés.
Composante : wd260ggl.dll
Version minimum requise
  • Version 14
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire