PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE

  • Exemple : Parcours d'agendas Google
  • Exemple : Ecrire un événement dans l'agenda Google
  • Exemple : Rechercher un événement dans l'agenda Google
GglListeAgenda (Exemple)
Exemple : Parcours d'agendas Google
Cet exemple permet de parcourir les différents agendas d'un compte Google. Pour chaque agenda, les événements associés sont parcourus, et pour chaque événement, les lieux associés sont parcourus.
// Connexion à Google
Cnx est un gglConnexion
...

// Récupération du tableau des agendas disponibles
tabAgendas est un tableau de gglAgenda
tabAgendas = GglListeAgenda(Cnx)

// Parcours
tabAgendasParcoursEvénement est un gglAgenda
UnAgenda est un gglAgenda
UnEvénement est un gglEvénement
UnLieu est un gglLieu

// Parcours de tous les agendas disponibles, on récupère les événements
POUR TOUT ELEMENT UnAgenda DE tabAgendas
Trace("Agenda " + UnAgenda..Titre + ...
" (mis à jour le " + DateVersChaîne(UnAgenda..DateMiseAJour[[A 8]]) + ...
" à " + HeureVersChaîne(UnAgenda..DateMiseAJour[[9 A]]) + ")")
tabAgendasParcoursEvénement = GglRécupèreAgenda(Cnx, UnAgenda..Identifiant)

// Parcours de tous les événements de l'agenda en cours
POUR TOUT UnEvénement DE tabAgendasParcoursEvénement
Trace("------------------------------")
Trace(UnEvénement..Titre)
Trace("Du " + DateVersChaîne(UnEvénement..DateDébut[[A 8]]) + ...
" à " + HeureVersChaîne(UnEvénement..DateDébut[[9 A]]) + ")" + ...
" au " + DateVersChaîne(UnEvénement..DateFin[[A 8]]) + " à " + ...
HeureVersChaîne(UnEvénement..DateFin[[9 A]]) + ")")  

// Parcours des lieux de l'événement
POUR TOUT ELEMENT UnLieu DE UnEvénement..Lieu
Trace("Lieu de l'événement : " + UnLieu..Valeur + "//" + UnLieu..Libellé)
FIN
FIN
FIN
Exemple : Ecrire un événement dans l'agenda Google
Cet exemple permet d'écrire un événement dans l'agenda Google sélectionné.
MaConnexion est une gglConnexion
MonAgenda est un gglAgenda
MonEvénement est un gglEvénement
tabMesAgendas est un tableau de gglAgendas
i est un entier
 
...
 
// Récupération de l'agenda
tabMesAgendas = GglListeAgenda(MaConnexion)
i = TableauCherche(tabMesAgendas, tcLinéaire, "Titre", "Test")
SI i = -1 ALORS
MonAgenda..Titre = "Test"
SINON
MonAgenda = GglRécupèreAgenda(MaConnexion, "Test")
FIN
 
// Création de l'événement
MonEvénement..Contenu = "STG"
MonEvénement..DateDébut = "20160906000000"
MonEvénement..DateFin = "20160907000000"
MonEvénement..JournéeEntière = Vrai
MonEvénement..Titre = "STG"
 
 
// Ajout de l'événement dans l'agenda et écriture de celui-ci
Ajoute(MonAgenda.Evénement, MonEvénement)
SI PAS GglEcrit(MaConnexion, MonAgenda) ALORS
Erreur(ErreurInfo())
FIN
Exemple : Rechercher un événement dans l'agenda Google
Cet exemple montre comment rechercher un événement dans un agenda Google
MaConnexion est une gglConnexion
MonAgenda est un gglAgenda
MonEvénement est un gglEvénement
tabMesAgendas est un tableau de gglAgendas
i est un entier
sMonEvénement est une chaîne
 
...
 
// Récupération de l'Agenda
tabMesAgendas = GglListeAgenda(MaConnexion)
i = TableauCherche(tabMesAgendas, tcLinéaire, "Titre", "STG")
SI i = -1 ALORS
MonAgenda..Titre = "Test"
SINON
// Récupération de l'événement
MonAgenda = GglRécupèreAgenda(MaConnexion, "STG")
MonEvénement = MonAgenda.Evénement[1]
FIN
 
sMonEvénement += [RC] + "Contenu : " + MonEvénement..Contenu
sMonEvénement += [RC] + "DateDébut : " + MonEvénement..DateDébut
sMonEvénement += [RC] + "DateFin : " + MonEvénement..DateFin
sMonEvénement += [RC] + "JournéeEntière : " + MonEvénement..JournéeEntière
sMonEvénement += [RC] + "Titre : " + MonEvénement..Titre
 
Info(sMonEvénement)
Version minimum requise
  • Version 14
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire