PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE

  • Intitulé d'une colonne d'un fichier XLS
xlsTitreColonne (Exemple)
Intitulé d'une colonne d'un fichier XLS
Le code suivant permet d'obtenir l'intitulé d'une colonne d'un fichier XLS. Les colonnes entièrement vides ne sont pas prises en compte (booléen Vrai). Ce fichier est préalablement ouvert avec la fonction xlsOuvre.
// Déclaration des variables
IDFichierXLS est un entier
ResTitreColonne est une chaîne
// Ouverture d'un fichier XLS
IDFichierXLS = xlsOuvre("C:\MesRépertoires\MesFichiers\Fichier.XLS")
SI IDFichierXLS <> -1 ALORS
// Titre de la colonne
ResTitreColonne = xlsTitreColonne(IDFichierXLS, 3, Vrai)
SI ResTitreColonne <> xlsTitreErreur ALORS
SI ResTitreColonne = "" ALORS
// La colonne n'a pas de titre
Info("La colonne n'a pas de titre")
SINON
 // Affichage du titre de la colonne
 Info("Le titre de la colonne est : " + ResTitreColonne)
FIN
SINON
// Affichage du message d'erreur si la récupération n'a pas été effectuée
Erreur(xlsMsgErreur(IDFichierXLS))
FIN
SINON
// Affichage du message d'erreur si l'ouverture n'a pas été effectuée
 Erreur(xlsMsgErreur(IDFichierXLS))
FIN
// Fermeture du fichier XLS
xlsFerme(IDFichierXLS)
Version minimum requise
  • Version 9
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire