PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE


  • Lecture du dernier email reçu dans la boîte aux lettres POP3
EmailLitDernier (Exemple)
Lecture du dernier email reçu dans la boîte aux lettres POP3
Le code suivant permet de lire le dernier email reçu. Si l'utilisateur le désire, le contenu de l'email est affiché dans la fenêtre "FEN_Email_RCV".
SI EmailOuvreSession(USER, PASSWORD, "pop3.yahoo.com", ...
"smtp.yahoo.com") = Vrai ALORS
NomUser = USER
SINON
NomUser = ""
Erreur("Impossible d'établir la connexion")
FIN
...
// Lecture du dernier enregistrement reçu
SI EmailLitDernier(NomUser) = Vrai ALORS
// Vérification de l'existence de l'email
SI Email.EnDehors = Faux ALORS
SI OuiNon("Vous avez reçu un email de" + Email.Expéditeur + ...
"Voulez-vous le lire ?") = Vrai ALORS
// Ouverture de la fenêtre permettant de lire l'email
Ouvre(FEN_Email_RCV)
FIN
SINON
Info("Pas de mail")
FIN
SINON
// Affichage de l'erreur rencontrée lors de la lecture de l'email
Erreur()
FIN
Version minimum requise
  • Version 9
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire