PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE

Nouveauté WINDEV Mobile 27 !
WINDEV
WindowsLinuxUniversal Windows 10 AppJavaEtats et RequêtesCode Utilisateur (MCU)
WEBDEV
WindowsLinuxPHPWEBDEV - Code Navigateur
WINDEV Mobile
AndroidWidget AndroidiPhone/iPadWidget IOSApple WatchMac CatalystUniversal Windows 10 App
Autres
Procédures stockées
CaméraVidéoDémarre (Fonction)
En anglais : CameraVideoStart
Démarre l'enregistrement d'une vidéo via un champ Caméra dans une application Android ou iOS. Les différentes options précisées pour le champ Caméra (flash, caméra dorsale ou frontale, ...) sont prises en compte.
Pour arrêter l'enregistrement de la vidéo, utilisez la fonction CameraVidéoArrête. La vidéo est sauvée dans le répertoire par défaut de l'application ou dans le répertoire spécifié avec la propriété RépertoireDeTravail.
Remarque : Cette fonction est utilisable uniquement avec un champ Caméra en version 27 ou supérieure (le champ ne doit pas avoir l'option "Mode compatible 26" cochée dans l'onglet "Général" de la fenêtre de description du champ).
Exemple
// Code de clic sur le champ BTN_Démarre_video
ChronoDébut()
 
TimerSys(TimerSys_Callback, 1s)
PROCÉDURE INTERNE TimerSys_Callback()
dDurée est une Durée = ChronoValeur()
LIB_CPT_VIDEO = DuréeVersChaîne(dDurée, "HH:MM:SS")
FIN
 
CaméraVidéoDémarre(CAM_Caméra, CaméraVidéoDémarre_Callback)
 
 
PROCÉDURE INTERNE CaméraVidéoDémarre_Callback(bRéussite est un booléen, CheminVidéo est une chaîne)
ChronoFin()
FinTimerSys()
LIB_CPT_VIDEO = "00:00:00"
SI bRéussite ALORS
LIB_CHEMIN_VIDEO = CheminVidéo
MaFenêtre.Plan = 4
SINON
ToastAffiche("Erreur lors de l'enregistrement de la vidéo." + RC + ErreurInfo())
FIN
FIN
// Arrêt de la vidéo
CaméraVidéoArrête(CAM_Caméra)
Syntaxe
CaméraVidéoDémarre(<Champ Caméra> , <Procédure WLangage>)
<Champ Caméra> : Nom de champ
Nom du champ Caméra qui effectue l'enregistrement de la vidéo.
<Procédure WLangage> : Nom de procédure
Nom de la procédure WLangage (également nommée "callback") appelée lorsque l'enregistrement de la vidéo est terminé (la fonction CameraVidéoArrête a été appelée).
Pour plus de détails sur cette procédure, consultez Paramètres de la procédure utilisée par la fonction CaméraVidéoDémarre.
Composante : wd270android.aar
Version minimum requise
  • Version 27
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire