PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE

Nouveauté WINDEV Mobile 27 !
WINDEV
WindowsLinuxUniversal Windows 10 AppJavaEtats et RequêtesCode Utilisateur (MCU)
WEBDEV
WindowsLinuxPHPWEBDEV - Code Navigateur
WINDEV Mobile
AndroidWidget AndroidiPhone/iPadWidget IOSApple WatchMac CatalystUniversal Windows 10 App
Autres
Procédures stockées
Arrête l'enregistrement d'une vidéo précédemment démarré par la fonction CaméraVidéoDémarre.

Remarque : Cette fonction est utilisable uniquement avec un champ Caméra en version 27 ou supérieure (le champ ne doit pas avoir l'option "Mode compatible 26" cochée dans l'onglet "Général" de la fenêtre de description du champ).
Exemple
// Code de clic sur le champ BTN_Démarre_video
ChronoDébut()
 
TimerSys(TimerSys_Callback, 1s)
PROCÉDURE INTERNE TimerSys_Callback()
dDurée est une Durée = ChronoValeur()
LIB_CPT_VIDEO = DuréeVersChaîne(dDurée, "HH:MM:SS")
FIN
 
CaméraVidéoDémarre(CAM_Caméra, CaméraVidéoDémarre_Callback)
 
 
PROCÉDURE INTERNE CaméraVidéoDémarre_Callback(bRéussite est un booléen, CheminVidéo est une chaîne)
ChronoFin()
FinTimerSys()
LIB_CPT_VIDEO = "00:00:00"
SI bRéussite ALORS
LIB_CHEMIN_VIDEO = CheminVidéo
MaFenêtre.Plan = 4
SINON
ToastAffiche("Erreur lors de l'enregistrement de la vidéo." + RC + ErreurInfo())
FIN
FIN
// Arrêt de la vidéo
CaméraVidéoArrête(CAM_Caméra)
Syntaxe
CaméraVidéoArrête(<Champ Caméra>)
<Champ Caméra> : Nom de champ
Nom du champ Caméra qui enregistre la vidéo.
Composante : wd270android.aar
Version minimum requise
  • Version 27
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire