PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE


Nouveauté WINDEV 26 !
  • Présentation
  • Comment le faire ?
  • Personnaliser les bulles d'aide
  • Cas particulier : Utiliser une fenêtre de l'application pour personnaliser les bulles d'aide
  • Fonctions et propriétés WLangage
WINDEV
WindowsLinuxUniversal Windows 10 AppJavaEtats et RequêtesCode Utilisateur (MCU)
WEBDEV
WindowsLinuxPHPWEBDEV - Code Navigateur
WINDEV Mobile
AndroidWidget AndroidiPhone/iPadWidget iOSApple WatchCatalystUniversal Windows 10 AppWindows Mobile
Autres
Procédures stockées
Présentation
Les bulles d'aide permettent d'aider rapidement l'utilisateur dans vos applications.
A partir de la version 26, finies les bulles d'aide tristes : utilisez les bulles d'aide personnalisées pour afficher vos messages. Plusieurs types de bulles d'aide sont disponibles :
  • Bulles d'aide standard :
  • Bulles d'aide du gabarit:
  • Bulles d'aide avec un style personnalisé:
  • Bulles d'aide personnalisées via une fenêtre de l'application.
Rappel : Le texte affiché dans la bulle d'aide peut être :
  • Saisi sous l'éditeur :
    1. Affichez la fenêtre de description du champ (option "Description" du menu contextuel).
    2. Dans l'onglet "Aide", dans la zone "Bulle d'aide", saisissez le texte de la bulle d'aide.
      Remarques :
      • Dans une application multilangue, le texte de la bulle d'aide peut être saisi dans les différentes langues.
      • Versions 21 et supérieures
        WINDEV Si l'option "RTF" est cochée, le texte peut être mis en forme grâce aux options de la barre d'outils RTF affichée. En exécution, la mise en forme sera respectée.
        Nouveauté 21
        WINDEV Si l'option "RTF" est cochée, le texte peut être mis en forme grâce aux options de la barre d'outils RTF affichée. En exécution, la mise en forme sera respectée.
        WINDEV Si l'option "RTF" est cochée, le texte peut être mis en forme grâce aux options de la barre d'outils RTF affichée. En exécution, la mise en forme sera respectée.
  • Indiqué en programmation grâce à la propriété Bulle.
Remarques :
  • Les bulles d'aide personnalisées sont utilisées pour toutes les bulles d'aide de l'application :
    • Bulles d'aide des champs.
    • Bulles d'aide automatiques des champs Table et Liste (affichées par exemple si le texte n'est pas complet dans le champ).
  • Les bulles d'aide personnalisées ne sont pas utilisées dans les cas suivants :
    • Bulles d'aide du champ Graphe.
    • Bulles d'aide des ascenseurs.
  • Si vos utilisateurs personnalisent le texte des bulles d'aide via la FAA, le texte personnalisé s'affichera dans la bulle d'aide personnalisée.
Comment le faire ?

Personnaliser les bulles d'aide

Pour personnaliser les bulles d'aide de votre application :
  1. Affichez la fenêtre de description du projet : sous le volet "Projet", dans le groupe "Projet", cliquez sur "Description".
  2. Dans l'onglet "Style", spécifiez le type de bulle d'aide à utiliser pour le projet :
    • Standard : les bulles d'aide sont standard, affichées sur fond jaune bulle.
    • Défini par le gabarit : les bulles d'aide utilisées sont les bulles d'aide présentes dans le gabarit utilisé par le projet.
    • Personnalisé : l'éditeur de styles de la bulle d'aide s'affiche afin de définir les options de personnalisation :
      Il est possible de personnaliser :
      • Le libellé affiché : police, taille, ombre, couleur, ...
      • Le cadre de la bulle : marges, couleur de fond, type de cadre, ...
    • Fenêtre : Vous pouvez alors sélectionner une fenêtre de votre projet pour afficher l'aide sous forme de bulle. Cette option permet de réaliser toutes les UI possibles.
  3. Validez la fenêtre de description du projet. Toutes les bulles d'aide affichées par votre application utiliseront le look sélectionné.
Remarque : Une animation peut être effectuée à l'affichage des bulles d'aide. Pour activer cette animation :
  1. Affichez la fenêtre de description du projet : sous le volet "Projet", dans le groupe "Projet", cliquez sur "Description".
  2. Dans l'onglet "Avancé", cliquez sur le bouton "Animations des champs".
  3. Dans la zone "Bulle d'aide", sélectionnez l'animation voulue et saisissez ses paramètres.
  4. Validez.
  5. Validez la fenêtre de description du projet.

Cas particulier : Utiliser une fenêtre de l'application pour personnaliser les bulles d'aide

WINDEV donne la possibilité d'utiliser une fenêtre de l'application pour afficher le contenu des bulles d'aide.
Dans ce cas :
  • Seul le code de déclaration des globales de la fenêtre est exécuté.
  • Le code de déclaration des globales de la fenêtre doit contenir le code suivant :
    PROCEDURE DéclarationDeGlobalesDeFenêtre(TexteDeLaBulle, ChampSource)
    LIB_BULLE = TexteDeLaBulle
    où :
    • TexteDeLaBulle est le texte à afficher dans la bulle d'aide. Ce texte doit être affiché dans un champ Libellé présent dans la fenêtre (par exemple LIB_BULLE).
    • ChampSource est un paramètre optionnel qui contient le nom du champ pour lequel la bulle d'aide est affichée.
  • L'option "Adapter la taille en fonction du contenu" (onglet "Général" de la fenêtre de description) doit être cochée.
  • La fenêtre doit utiliser une image de fond avec l'option de détourage (option "Détourer la fenêtre (utilise le mode de transparence de l'image de fond)" dans l'onglet "Image" de la fenêtre de description).
  • Pour afficher un texte avec des effets dans la bulle d'aide, il est possible par exemple : Ces informations doivent être renseignées au niveau de la bulle d'aide du champ (par exemple dans l'onglet "Aide" de la fenêtre de description du champ ou via la propriété Bulle du champ).
  • Des options spécifiques sont disponibles dans le volet "Modifieur", pour les fenêtres affichées en mode bulle d'aide. Ces options sont les suivantes :
    • "Mode bulle d'aide" : Permet d'activer ou non le mode d'affichage en bulle d'aide. Si ce mode est activé, les autres options du mode bulle seront prises en compte.
    • "Mode Bulle : Décalage X" : Permet de définir le décalage en X de la fenêtre (affichée sous forme de bulle) par rapport au curseur de la souris. Le curseur de la souris correspond au point (0,0).
    • "Mode Bulle : Décalage Y" : Permet de définir le décalage en Y de la fenêtre (affichée sous forme de bulle) par rapport au curseur de la souris. Le curseur de la souris correspond au point (0,0).
    • "Mode Bulle : Point chaud" : Permet de définir le point de la fenêtre (affichée sous forme de bulle) qui sera affiché à la position du curseur de la souris. Cette option permet notamment de réaliser des bulles d'aide de type phylactère.
Fonctions et propriétés WLangage
Plusieurs fonctions et propriétés WLangage sont utilisables pour paramétrer les bulles d'aide.
Les fonctions et propriétés suivantes peuvent être utilisées sur les bulles d'aide personnalisées :
  • Fonctions WLangage :
    Versions 09 et supérieures
    BulleActive
    Nouveauté 09
    BulleActive
    BulleActive
    Active ou désactive le mécanisme d'affichage des bulles d'aide sur les champs.
    Versions 10 et supérieures
    BulleDélai
    Nouveauté 10
    BulleDélai
    BulleDélai
    Permet de modifier :
    • le délai à attendre avant l'affichage des bulles d'aide.
    • la durée d'affichage des bulles d'aide des champs.
    Versions 22 et supérieures
    BulleLargeurMax
    Nouveauté 22
    BulleLargeurMax
    BulleLargeurMax
    Modifie la largeur maximale des bulles d'aide.
  • Propriétés WLangage :
    Versions 09 et supérieures
    Bulle
    Nouveauté 09
    Bulle
    Bulle
    La propriété Bulle permet de connaître et de modifier le texte affiché dans la bulle d'aide associée à un champ d'une fenêtre ou d'une page.
    Versions 15 et supérieures
    BulleAutomatique
    Nouveauté 15
    BulleAutomatique
    BulleAutomatique
    La propriété BulleAutomatique permet d'autoriser ou non l'affichage des bulles automatiques sur les champs Liste, Table et Table hiérarchique.
Version minimum requise
  • Version 26
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire