DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE

Aide / Editeurs / Editeur de projet / Description du projet
  • Présentation
  • Onglet Projet
  • Divers
  • Correcteur orthographique
  • Synchronisation des modèles
  • Développement en mode strict
  • Charte de programmation
WINDEV
WindowsLinuxUniversal Windows 10 AppJavaEtats et RequêtesCode Utilisateur (MCU)
WEBDEV
WindowsLinuxPHPWEBDEV - Code Navigateur
WINDEV Mobile
AndroidWidget AndroidiPhone/iPadWidget IOSApple WatchMac CatalystUniversal Windows 10 App
Autres
Procédures stockées
Présentation
La fenêtre de description du projet permet de configurer de nombreux éléments de votre projet. Cette fenêtre est constituée des onglets suivants :
  • L'onglet "Projet" qui permet de saisir les informations générales du projet
  • L'onglet "Analyse" qui permet d'associer une analyse au projet et / ou un modèle UML
  • L'onglet "Fichiers" qui permet de saisir différentes informations sur les fichiers de données gérés par l'application (uniquement disponible si le projet est lié à une analyse).
  • L'onglet "Live data" qui permet de configurer l'affichage des données (provenant des fichiers de données) sous les différents éditeurs.
  • L'onglet "Langues" qui permet de paramétrer les différentes langues manipulées par le projet ainsi que les options linguistiques à utiliser pour chaque langue.
  • L'onglet "Style" qui permet de choisir le thème de gabarit, la feuille de styles personnalisée et de personnaliser l'aperçu avant impression. Il est également possible de paramétrer la taille des écrans.
  • L'onglet "GDS" qui permet de gérer le travail en groupe (GDS ou GIT).
  • L'onglet "Options" qui permet de configurer les options de mise à jour, de sauvegarde, de synchronisation des modèles. Cet onglet permet également d'activer le mode strict et de définir la charte de programmation.
  • L'onglet "Avancé" qui permet de gérer l'utilisation de "Etats & Requêtes", les FAA et le verrouillage de l'application.
  • L'onglet "Compilation" qui permet de configurer les options de compilation.
  • L'onglet "Télémétrie" qui permet de configurer les options de télémétrie pour le projet.
Onglet Projet

Divers

Les options diverses sont les suivantes :
  • "Demander l'emplacement des nouveaux éléments dans le projet" : Si cette option est sélectionnée, lors de l'enregistrement d'un nouvel élément dans le projet, l'emplacement de cet élément est systématiquement demandé.
  • "Générer toutes les configurations dans le répertoire "Exe" (déconseillé si plusieurs configurations)" : Si cette option est sélectionnée, toutes les configurations seront générées dans le même répertoire. Si cette option n'est pas sélectionnée, chaque configuration de projet sera générée dans un sous-répertoire du répertoire 'Exe" du projet. Ce sous-répertoire de génération aura pour nom celui de la configuration de projet.
  • "Inclure les nouveaux éléments uniquement dans la configuration courante" : Si cette option est sélectionnée, par défaut, tous les nouveaux éléments du projet seront automatiquement inclus uniquement dans la configuration de projet en cours sous l'éditeur.
  • "Le projet ne génère qu'une seule application pour le Store Privé (pour compatibilité)" : Cette option permet d'indiquer si le paramétrage du serveur qui héberge l'installation de l'application pour le Store Privé sera effectué par configuration de projet. Si cette option est cochée, le paramétrage du serveur sera identique pour toutes les configurations de projet. Si cette option est décochée (par défaut), les paramètres de configuration du Store Privé pourront être différents par configuration de projet.
  • Format de sauvegarde des éléments : Il est possible de choisir un format Binaire ou un format texte. Le format texte est nécessaire pour le partage de fichiers via Git. Pour plus de détails, consultez Partagez vos projets via Git.
WINDEV

Correcteur orthographique

Cette option permet de :
  • Choisir le correcteur orthographique utilisé. Ce correcteur orthographique sera utilisé par défaut pour la correction orthographique réalisée dans les champs de saisie et dans les champs Traitement de texte.
  • "Copier automatiquement les dictionnaires dans le répertoire de génération" : Si cette option est sélectionnée, les dictionnaires correspondant aux langues de l'application seront automatiquement copiés dans le répertoire de génération lors de la génération de l'application.

Synchronisation des modèles

L'option "Synchroniser les modèles lors de la génération" permet d'automatiser la synchronisation des modèles de champs, de fenêtres, de pages ou d'états lors de la génération de l'application.

Développement en mode strict

Le développement en mode strict consiste à utiliser les tâches définies dans le Centre de Suivi de Projet pour le développement.
Si l'option "Activer le mode strict" est sélectionnée, le développeur ne pourra pas modifier un élément du projet sans avoir auparavant sélectionné la tâche concernée par ces modifications.

Charte de programmation

Une charte de programmation permet de préfixer automatiquement le nom de toutes les variables et de tous les éléments du projet (fenêtre, champ d'un état, classe, ...). Ce préfixage automatique permet de connaître et/ou de rechercher facilement un élément d'un type donné.
Pour mettre en place de la charte de programmation dans le projet, il suffit de sélectionner l'option "Activer le préfixage automatique des variables et des éléments du projet". Il est alors possible de :
  • choisir la charte de programmation voulue.
    Les boutons "Créer une charte de programmation" et "Editer la charte" permettent de créer et personnaliser sa propre charte de programmation.
  • d'ajouter ou non automatiquement les préfixes (option "Ajouter automatiquement les préfixes").
  • générer une erreur d'UI en cas de préfixe invalide (option "Lever une erreur de compilation d'UI si un champ n'a pas le bon préfixe").
Pour plus de détails, consultez Charte de programmation.
Version minimum requise
  • Version 10
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire

Dernière modification : 21/08/2023

Signaler une erreur ou faire une suggestion | Aide en ligne locale