PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEV, WEBDEV ET WINDEV MOBILE

  • Codes d'erreur
  • Taux de compression et temps d'ajout
  • Notes
WINDEV
WindowsLinuxUniversal Windows 10 AppJavaEtats et RequêtesCode Utilisateur (MCU)
WEBDEV
WindowsLinuxPHPWEBDEV - Code Navigateur
WINDEV Mobile
AndroidWidget AndroidiPhone/iPadApple WatchUniversal Windows 10 AppWindows Mobile
Autres
Procédures stockées
Change le niveau de compression utilisé dans la création d'une archive au format ZIP ou au format 7z.
Versions 15 et supérieures
Java Cette fonction est désormais disponible pour les applications Java.
Android Cette fonction est désormais disponible pour les applications Android.
Nouveauté 15
Java Cette fonction est désormais disponible pour les applications Java.
Android Cette fonction est désormais disponible pour les applications Android.
Java Cette fonction est désormais disponible pour les applications Java.
Android Cette fonction est désormais disponible pour les applications Android.
Versions 17 et supérieures
iPhone/iPad Cette fonction est désormais disponible pour les applications iPhone/iPad.
Nouveauté 17
iPhone/iPad Cette fonction est désormais disponible pour les applications iPhone/iPad.
iPhone/iPad Cette fonction est désormais disponible pour les applications iPhone/iPad.
Versions 18 et supérieures
Widget Android Cette fonction est désormais disponible en mode Widget Android.
WINDEVWEBDEV - Code ServeurWindows Cette fonction gère désormais le format 7z.
Nouveauté 18
Widget Android Cette fonction est désormais disponible en mode Widget Android.
WINDEVWEBDEV - Code ServeurWindows Cette fonction gère désormais le format 7z.
Widget Android Cette fonction est désormais disponible en mode Widget Android.
WINDEVWEBDEV - Code ServeurWindows Cette fonction gère désormais le format 7z.
Versions 19 et supérieures
Universal Windows 10 App Cette fonction est désormais disponible en mode Windows Store apps.
Nouveauté 19
Universal Windows 10 App Cette fonction est désormais disponible en mode Windows Store apps.
Universal Windows 10 App Cette fonction est désormais disponible en mode Windows Store apps.
Versions 21 et supérieures
Universal Windows 10 App Cette fonction est désormais disponible en mode Universal Windows 10 App.
Nouveauté 21
Universal Windows 10 App Cette fonction est désormais disponible en mode Universal Windows 10 App.
Universal Windows 10 App Cette fonction est désormais disponible en mode Universal Windows 10 App.
Exemple
NumErrZip est un entier
 
// Création de l'archive "MonArchive"
NumErrZip = zipCrée("MonArchive", "C:\MesDocuments\Archive.zip")
SI NumErrZip <> 0 ALORS
Erreur(zipMsgErreur(NumErrZip))
RETOUR
FIN
 
// Ajout d'un fichier au taux de compression par défaut (6)
NumErrZip = zipAjouteFichier("MonArchive", "C:\MesImages\Image1.jpg", zipAucun)
SI NumErrZip <> 0 ALORS
Erreur(zipMsgErreur(NumErrZip) + "Sur le fichier " + zipFichierEnCours("MonArchive"))
FIN
 
// Changement du taux de compression
// Le prochain fichier sera simplement stocké (aucune compression)
zipNiveauCompression("MonArchive", 0)
 
// Ajout d'un fichier
NumErrZip = zipAjouteFichier("MonArchive", "C:\MesImages\Image2.jpg", zipAucun)
SI NumErrZip <> 0 ALORS
Erreur(zipMsgErreur(NumErrZip) + "Sur le fichier " + zipFichierEnCours("MonArchive"))
FIN
 
WINDEVWEBDEV - Code ServeurEtats et RequêtesWindows MobileAjax
NumErrZip est un entier
MonArchive est un zipArchive
 
// Création de l'archive "MonArchive"
NumErrZip = zipCrée(MonArchive, "C:\MesDocuments\Archive.zip")
SI NumErrZip <> 0 ALORS
Erreur(zipMsgErreur(NumErrZip))
RETOUR
FIN
 
// Ajout d'un fichier au taux de compression par défaut (6)
NumErrZip = zipAjouteFichier(MonArchive, "C:\MesImages\Image1.jpg", zipAucun)
SI NumErrZip <> 0 ALORS
Erreur(zipMsgErreur(NumErrZip) + "Sur le fichier " + zipFichierEnCours(MonArchive))
FIN
 
// Changement du taux de compression
// Le prochain fichier sera simplement stocké (aucune compression)
zipNiveauCompression(MonArchive, 0)
 
// Ajout d'un fichier
NumErrZip = zipAjouteFichier(MonArchive, "C:\MesImages\Image2.jpg", zipAucun)
SI NumErrZip <> 0 ALORS
Erreur(zipMsgErreur(NumErrZip) + "Sur le fichier " + zipFichierEnCours(MonArchive))
FIN
 
Syntaxe
<Résultat> = zipNiveauCompression(<Archive> , <Niveau de compression>)
<Résultat> : Entier
  • 0 si le niveau de compression a bien été changé,
  • Un code d'erreur (valeur supérieure à 0) dans le cas contraire (voir les Notes).
<Archive> : Chaîne de caractères (avec guillemets) ou variable de type zipArchive
Nom de l'archive à manipuler.
Ce nom peut correspondre :
  • soit au nom d'une archive défini avec la fonction zipOuvre ou la fonction zipCrée.
  • Versions 15 et supérieures
    WINDEVWEBDEV - Code ServeurEtats et RequêtesWindows MobileAjax soit au nom d'une variable de type zipArchive.
    Nouveauté 15
    WINDEVWEBDEV - Code ServeurEtats et RequêtesWindows MobileAjax soit au nom d'une variable de type zipArchive.
    WINDEVWEBDEV - Code ServeurEtats et RequêtesWindows MobileAjax soit au nom d'une variable de type zipArchive.
<Niveau de compression> : Entier
Valeur comprise entre 0 (simple stockage sans compression) et 9 (compression maximale).
Par défaut, le taux de compression utilisé est de 6.
Remarques

Codes d'erreur

Les codes d'erreur retournés sont les suivants :
  • 15 : Archive au format CAB.
  • 27 : Archive au format WDZ.
  • 28 : Niveau de compression invalide.
Le message correspondant au code d'erreur peut être connu grâce à la fonction zipMsgErreur.

Taux de compression et temps d'ajout

Attention : Plus le niveau de compression est élevé, plus l'ajout d'un fichier dans l'archive prendra du temps.

Notes

Le niveau de compression est fixé par l'appel à la fonction pour tous les fichiers qui seront ajoutés dans l'archive par la suite (le niveau des fichiers déjà ajouté reste inchangé).
Attention : Il n'est pas possible de changer le niveau de compression d'un fichier dans une archive déjà existante.
Composante : wd240zip.dll
Version minimum requise
  • Version 11
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire