PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE

WINDEV
WindowsLinuxUniversal Windows 10 AppJavaEtats et RequêtesCode Utilisateur (MCU)
WEBDEV
WindowsLinuxPHPWEBDEV - Code Navigateur
WINDEV Mobile
AndroidWidget AndroidiPhone/iPadApple WatchUniversal Windows 10 AppWindows Mobile
Autres
Procédures stockées
Renvoie le nombre de fichiers présents dans une archive (au format CAB, RAR, ZIP, WDZ, 7z, TAR ou TAGZ).
Versions 15 et supérieures
Android Cette fonction est désormais disponible pour les applications Android.
Nouveauté 15
Android Cette fonction est désormais disponible pour les applications Android.
Android Cette fonction est désormais disponible pour les applications Android.
Versions 17 et supérieures
iPhone/iPad Cette fonction est désormais disponible pour les applications iPhone/iPad.
Nouveauté 17
iPhone/iPad Cette fonction est désormais disponible pour les applications iPhone/iPad.
iPhone/iPad Cette fonction est désormais disponible pour les applications iPhone/iPad.
Versions 18 et supérieures
Widget Android Cette fonction est désormais disponible en mode Widget Android.
WINDEVWEBDEV - Code ServeurWindows Cette fonction gère désormais le format 7z.
Nouveauté 18
Widget Android Cette fonction est désormais disponible en mode Widget Android.
WINDEVWEBDEV - Code ServeurWindows Cette fonction gère désormais le format 7z.
Widget Android Cette fonction est désormais disponible en mode Widget Android.
WINDEVWEBDEV - Code ServeurWindows Cette fonction gère désormais le format 7z.
Versions 19 et supérieures
Universal Windows 10 App Cette fonction est désormais disponible en mode Windows Store apps.
Nouveauté 19
Universal Windows 10 App Cette fonction est désormais disponible en mode Windows Store apps.
Universal Windows 10 App Cette fonction est désormais disponible en mode Windows Store apps.
Versions 21 et supérieures
Universal Windows 10 App Cette fonction est désormais disponible en mode Universal Windows 10 App.
WINDEVWEBDEV - Code ServeurWindowsLinuxiPhone/iPadUniversal Windows 10 App Cette fonction gère désormais les formats TAR et TGZ (TAR.GZ).
Nouveauté 21
Universal Windows 10 App Cette fonction est désormais disponible en mode Universal Windows 10 App.
WINDEVWEBDEV - Code ServeurWindowsLinuxiPhone/iPadUniversal Windows 10 App Cette fonction gère désormais les formats TAR et TGZ (TAR.GZ).
Universal Windows 10 App Cette fonction est désormais disponible en mode Universal Windows 10 App.
WINDEVWEBDEV - Code ServeurWindowsLinuxiPhone/iPadUniversal Windows 10 App Cette fonction gère désormais les formats TAR et TGZ (TAR.GZ).
WINDEVWEBDEV - Code ServeurEtats et RequêtesJavaAjaxCode Utilisateur (MCU)
// Ouverture d'une archive
ResOuvreArchive = zipOuvre("MonArchive", "C:\MesArchives\Archive.zip")
SI ResOuvreArchive = 0 ALORS
...
// Nombre de fichiers dans l'archive
ResNbFichier = zipNbFichier("MonArchive")
Info(ResNbFichier + " fichiers présents dans cette archive")
...
FIN
 
WINDEVWEBDEV - Code ServeurEtats et RequêtesAjaxCode Utilisateur (MCU)
MonArchive est un zipArchive
// Ouverture d'une archive
ResOuvreArchive = zipOuvre(MonArchive, "C:\MesArchives\Archive.zip")
SI ResOuvreArchive = 0 ALORS
...
// Nombre de fichiers dans l'archive
ResNbFichier = zipNbFichier(MonArchive)
Info(ResNbFichier + " fichiers présents dans cette archive")
...
FIN
 
Windows Mobile
// Ouverture d'une archive
ResOuvreArchive = zipOuvre("MonArchive", "\MesArchives\Archive.zip")
SI ResOuvreArchive = 0 ALORS
...
// Nombre de fichiers dans l'archive
ResNbFichier = zipNbFichier("MonArchive")
Info(ResNbFichier + " fichiers présents dans cette archive")
...
FIN
 
Windows Mobile
MonArchive est un zipArchive
// Ouverture d'une archive
ResOuvreArchive = zipOuvre(MonArchive, "\MesArchives\Archive.zip")
SI ResOuvreArchive = 0 ALORS
...
// Nombre de fichiers dans l'archive
ResNbFichier = zipNbFichier(MonArchive)
Info(ResNbFichier + " fichiers présents dans cette archive")
...
FIN
 
Syntaxe
<Résultat> = zipNbFichier(<Archive>)
<Résultat> : Entier
Nombre de fichiers présents dans l'archive spécifiée.
<Archive> : Chaîne de caractères (avec guillemets) ou variable de type zipArchive
Nom de l'archive à manipuler.
Ce nom peut correspondre :
  • soit au nom d'une archive défini avec la fonction zipOuvre ou la fonction zipCrée.
  • Versions 15 et supérieures
    WINDEVWEBDEV - Code ServeurEtats et RequêtesWindows MobileAjax soit au nom d'une variable de type zipArchive.
    Nouveauté 15
    WINDEVWEBDEV - Code ServeurEtats et RequêtesWindows MobileAjax soit au nom d'une variable de type zipArchive.
    WINDEVWEBDEV - Code ServeurEtats et RequêtesWindows MobileAjax soit au nom d'une variable de type zipArchive.
Remarques
  • LinuxiPhone/iPadUniversal Windows 10 App Seules les archives au format ZIP, TAR et TGZ (TAR.GZ) sont disponibles.
  • AndroidWidget AndroidWindows MobileJava Seules les archives au format ZIP sont disponibles.
Composante : wd240zip.dll
Version minimum requise
  • Version 9
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire