PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE

  • Codes d'erreur
WINDEV
WindowsLinuxUniversal Windows 10 AppJavaEtats et RequêtesCode Utilisateur (MCU)
WEBDEV
WindowsLinuxPHPWEBDEV - Code Navigateur
WINDEV Mobile
AndroidWidget AndroidiPhone/iPadWidget iOSApple WatchCatalystUniversal Windows 10 AppWindows Mobile
Autres
Procédures stockées
Renvoie le message associé à un code d'erreur sur une archive.
Versions 18 et supérieures
WEBDEV - Code ServeurWindows Cette fonction gère désormais le format 7z.
Nouveauté 18
WEBDEV - Code ServeurWindows Cette fonction gère désormais le format 7z.
WEBDEV - Code ServeurWindows Cette fonction gère désormais le format 7z.
// Ouverture d'une archive
ResOuvreArchive = zipOuvre("MonArchive")
// Erreur d'ouverture d'une archive
SI ResOuvreArchive <> 0 ALORS
// Affichage d'un message d'erreur
Info(zipMsgErreur(ResOuvreArchive))
...
FIN
 
MonArchive est un zipArchive
// Ouverture d'une archive
ResOuvreArchive = zipOuvre(MonArchive)
// Erreur d'ouverture d'une archive
SI ResOuvreArchive <> 0 ALORS
// Affichage d'un message d'erreur
Info(zipMsgErreur(ResOuvreArchive))
...
FIN
 
Syntaxe
<Résultat> = zipMsgErreur(<Code d'erreur>)
<Résultat> : Chaîne de caractères
Message d'erreur correspondant au code d'erreur spécifié.
<Code d'erreur> : Entier
Code d'erreur renvoyé lors de la manipulation d'une archive.
Remarques

Codes d'erreur

Les codes d'erreur retournés par les fonctions d'archivage sont les suivants :
  • 1 : Le chemin passé en paramètre n'existe pas.
  • 2 : Accès interdit : l'utilisateur n'a pas les droits nécessaires.
  • 3 : L'archive est corrompue.
  • 4 : Le chemin n'existe pas dans l'archive.
  • 5 : Impossible d'écrire dans l'archive.
  • 6 : Les fichiers des sous-archives ne sont pas dans l'ordre (cas d'une extraction dans une archive multi-parties).
  • 7 : Le fichier est déjà présent dans l'archive.
  • 8 : Une archive ne peut pas être ajoutée à elle-même. Par exemple, l'archive "MonArchive" ne peut pas être ajoutée à l'archive "MonArchive".
  • 10 : Pas assez de place pour créer l'exécutable, ou l'utilisateur n'a pas les droits en écriture sur l'archive originale (.WDZ).
  • 11 : L'icône n'a pas été trouvée ou l'icône n'est pas au bon format.
  • 12 : Pas assez de place pour créer l'exécutable, ou l'utilisateur n'a pas les droits en lecture sur l'archive originale (.WDZ).
Rappel :
  • Linux Seules les archives au format ZIP, TAR et TGZ (TAR.GZ) sont disponibles.
Composante : wd250zip.dll
Version minimum requise
  • Version 9
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire