PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE

  • Une archive multi-parties peut être constituée d'une seule partie
  • Rappel
WINDEV
WindowsLinuxUniversal Windows 10 AppJavaEtats et RequêtesCode Utilisateur (MCU)
WEBDEV
WindowsLinuxPHPWEBDEV - Code Navigateur
WINDEV Mobile
AndroidWidget AndroidiPhone/iPadApple WatchUniversal Windows 10 AppWindows Mobile
Autres
Procédures stockées
Renvoie le nombre de sous-archives (parties) d'une archive au format CAB, RAR, ZIP, WDZ, 7z, TAR ou TGZ (TAR.GZ).
Versions 17 et supérieures
iPhone/iPad Cette fonction est désormais disponible pour les applications iPhone/iPad.
Nouveauté 17
iPhone/iPad Cette fonction est désormais disponible pour les applications iPhone/iPad.
iPhone/iPad Cette fonction est désormais disponible pour les applications iPhone/iPad.
Versions 18 et supérieures
WINDEVWEBDEV - Code ServeurWindows Cette fonction gère désormais le format 7z.
Nouveauté 18
WINDEVWEBDEV - Code ServeurWindows Cette fonction gère désormais le format 7z.
WINDEVWEBDEV - Code ServeurWindows Cette fonction gère désormais le format 7z.
Versions 21 et supérieures
WINDEVWEBDEV - Code ServeurWindowsLinuxiPhone/iPad Cette fonction gère désormais les formats TAR et TGZ (TAR.GZ).
Nouveauté 21
WINDEVWEBDEV - Code ServeurWindowsLinuxiPhone/iPad Cette fonction gère désormais les formats TAR et TGZ (TAR.GZ).
WINDEVWEBDEV - Code ServeurWindowsLinuxiPhone/iPad Cette fonction gère désormais les formats TAR et TGZ (TAR.GZ).
WINDEVWEBDEV - Code ServeurEtats et RequêtesAjaxCode Utilisateur (MCU)
// Ouverture d'une archive
ResOuvreArchive = zipOuvre("MonArchive", "C:\MesArchives\Archive.zip")
SI ResOuvreArchive = 0 ALORS
...
// Nombre de parties présentes dans l'archive
ResNbPartie = zipNbPartie("MonArchive")
Info("Cette archive est composée de " + ResNbPartie + " partie(s)")
...
FIN
 
WINDEVWEBDEV - Code ServeurEtats et RequêtesAjaxCode Utilisateur (MCU)
MonArchive est un zipArchive
// Ouverture d'une archive
ResOuvreArchive = zipOuvre(MonArchive, "C:\MesArchives\Archive.zip")
SI ResOuvreArchive = 0 ALORS
...
// Nombre de parties présentes dans l'archive
ResNbPartie = zipNbPartie(MonArchive)
Info("Cette archive est composée de " + ResNbPartie + " partie(s)")
...
FIN
 
Windows Mobile
// Ouverture d'une archive
ResOuvreArchive = zipOuvre("MonArchive", "\MesArchives\Archive.zip")
SI ResOuvreArchive = 0 ALORS
...
// Nombre de parties présentes dans l'archive
ResNbPartie = zipNbPartie("MonArchive")
Info("Cette archive est composée de " + ResNbPartie + " partie(s)")
...
FIN
 
Windows Mobile
MonArchive est un zipArchive
// Ouverture d'une archive
ResOuvreArchive = zipOuvre(MonArchive, "\MesArchives\Archive.zip")
SI ResOuvreArchive = 0 ALORS
...
// Nombre de parties présentes dans l'archive
ResNbPartie = zipNbPartie(MonArchive)
Info("Cette archive est composée de " + ResNbPartie + " partie(s)")
...
FIN
 
Syntaxe
<Résultat> = zipNbPartie(<Archive>)
<Résultat> : Entier
Nombre de parties présentes dans l'archive spécifiée :
  • 1 : si l'archive est mono-partie ou si l'archive multi-parties contient une seule sous-archive.
  • n : si l'archive est multi-parties.
<Archive> : Chaîne de caractères (avec guillemets) ou variable de type zipArchive
Nom de l'archive à manipuler.
Ce nom peut correspondre :
  • soit au nom d'une archive défini avec la fonction zipOuvre ou la fonction zipCrée.
  • Versions 15 et supérieures
    WINDEVWEBDEV - Code ServeurEtats et RequêtesWindows MobileAjax soit au nom d'une variable de type zipArchive.
    Nouveauté 15
    WINDEVWEBDEV - Code ServeurEtats et RequêtesWindows MobileAjax soit au nom d'une variable de type zipArchive.
    WINDEVWEBDEV - Code ServeurEtats et RequêtesWindows MobileAjax soit au nom d'une variable de type zipArchive.
Remarques

Une archive multi-parties peut être constituée d'une seule partie

Une archive multi-parties peut être composée d'une seule sous-archive (partie). En effet, lors du découpage d'une archive, la taille spécifiée pour les sous-archives peut être supérieure à la taille de l'archive.

Rappel

  • LinuxiPhone/iPad Seules les archives au format ZIP, TAR et TGZ (TAR.GZ) sont disponibles.
  • Windows Mobile Seules les archives au format ZIP sont disponibles.
Composante : wd240zip.dll
Version minimum requise
  • Version 9
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire