PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE

  • Fonctions XML et threads
WINDEV
WindowsLinuxUniversal Windows 10 AppJavaEtats et RequêtesCode Utilisateur (MCU)
WEBDEV
WindowsLinuxPHPWEBDEV - Code Navigateur
WINDEV Mobile
AndroidWidget AndroidiPhone/iPadApple WatchUniversal Windows 10 AppWindows Mobile
Autres
Procédures stockées
XMLFilsExiste (Fonction)
En anglais : XMLChildExist
Indique si la balise courante a des fils correspondant au type recherché (balise, attribut, ...).
Versions 15 et supérieures
Android Cette fonction est désormais disponible pour les applications Android.
Nouveauté 15
Android Cette fonction est désormais disponible pour les applications Android.
Android Cette fonction est désormais disponible pour les applications Android.
Versions 17 et supérieures
iPhone/iPad Cette fonction est désormais disponible pour les applications iPhone/iPad.
Nouveauté 17
iPhone/iPad Cette fonction est désormais disponible pour les applications iPhone/iPad.
iPhone/iPad Cette fonction est désormais disponible pour les applications iPhone/iPad.
Versions 18 et supérieures
Widget Android Cette fonction est désormais disponible en mode Widget Android.
Universal Windows 10 App Cette fonction est désormais disponible en mode Windows Store apps.
Nouveauté 18
Widget Android Cette fonction est désormais disponible en mode Widget Android.
Universal Windows 10 App Cette fonction est désormais disponible en mode Windows Store apps.
Widget Android Cette fonction est désormais disponible en mode Widget Android.
Universal Windows 10 App Cette fonction est désormais disponible en mode Windows Store apps.
Versions 21 et supérieures
Universal Windows 10 App Cette fonction est désormais disponible en mode Universal Windows 10 App.
Nouveauté 21
Universal Windows 10 App Cette fonction est désormais disponible en mode Universal Windows 10 App.
Universal Windows 10 App Cette fonction est désormais disponible en mode Universal Windows 10 App.
Exemple
MonDoc est une chaîne
MonDoc = fChargeTexte("exemple.xml")
XMLDocument("exemple ", MonDoc)
SI ErreurDétectée = Vrai ALORS
Erreur("le fichier n'est pas au format XML")
RETOUR
FIN
// Parcourt le fichier et indique si la balise possède un attribut
XMLRecherche("exemple", Null)
TANTQUE XMLEnDehors("exemple") = Faux
SI XMLFilsExiste("exemple", XMLAttribut)
Trace(XMLNomElément("exemple") + " a des attributs")
SINON
Trace(XMLNomElément("exemple") + " n'a pas d'attributs")
FIN
XMLSuivant("exemple")
FIN
XMLTermine("exemple")
Syntaxe
<Résultat> = XMLFilsExiste(<Document XML> [, <Type du fils recherché>])
<Résultat> : Booléen
  • Vrai si la balise courante a des fils du type indiqué,
  • Faux dans le cas contraire.
<Document XML> : Chaîne de caractères (entre guillemets)
Nom du document XML manipulé. Ce document contient le code XML à analyser et a été créé avec la fonction XMLDocument.
<Type du fils recherché> : Constante optionnelle de type Entier
Type de fils recherché :
XMLAttributCherche les fils de type Attribut associés à la balise courante.
XMLBaliseCherche les fils de type Balise associés à la balise courante.
XMLAttribut + XMLBaliseCherche les fils de type Balise OU de type Attribut associés à la balise courante.
Remarques

Fonctions XML et threads

Si votre application utilise des threads, le document XML est partagé entre tous ces threads. Pour plus de détails sur la gestion des threads, consultez Gestion des threads.
Composante : wd240xml.dll
Version minimum requise
  • Version 9
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire