DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE


WINDEV
WindowsLinuxUniversal Windows 10 AppJavaEtats et RequêtesCode Utilisateur (MCU)
WEBDEV
WindowsLinuxPHPWEBDEV - Code Navigateur
WINDEV Mobile
AndroidWidget AndroidiPhone/iPadWidget IOSApple WatchMac CatalystUniversal Windows 10 App
Autres
Procédures stockées
XMLRésultat (Fonction)
En anglais : XMLResult
Donne le résultat d'une requête XPath de calcul. Cette requête a été exécutée avec la fonction XMLExécuteXPath.
Exemple
// Chargement du fichier XML
MonDoc est une chaîne
MonDoc = fChargeTexte("exemple.xml")
// Texte de la requête : Recherche de la balise Index
RequeteXPath est une chaîne = "Aide/Fonction/Index"
// Création du document
XMLDocument("Exemple", MonDoc)
SI ErreurDétectée = Vrai ALORS
Erreur("le fichier n'est pas au format XML")
RETOUR
FIN
b est un booléen
b = XMLExécuteXPath("Exemple", RequeteXPath)
// Est-ce une requête de calcul ?
SI b = Vrai ET XMLEnDehors("Exemple") = Vrai ALORS
 // Voilà le résultat du calcul
 Trace("XMLResultat = " + XMLRésultat("Exemple"))
FIN
// Est-ce une requête XPath de sélection ?
SI XMLTrouve("Exemple") = Vrai ALORS
// Parcours de la sélection résultat
TANTQUE XMLTrouve("Exemple") = Vrai
Trace(XMLPosition("Exemple"))
XMLSuivant("Exemple")
FIN
// Parcours terminé, on termine la requête
XMLAnnuleRecherche("Exemple")
FIN
Syntaxe
<Résultat> = XMLRésultat(<Document XML>)
<Résultat> : Type correspondant au résultat de la requête XPath
Résultat de la requête de calcul XPath exécutée avec la fonction XMLExécuteXPath.
<Document XML> : Chaîne de caractères
Nom du document XML manipulé. Ce document a été créé avec la fonction XMLDocument.
Classification Métier / UI : Code métier
Composante : wd280xml.dll
Version minimum requise
  • Version 9
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire