PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE

PV

WINDEV
WindowsLinuxUniversal Windows 10 AppJavaEtats et RequêtesCode Utilisateur (MCU)
WEBDEV
WindowsLinuxPHPWEBDEV - Code Navigateur
WINDEV Mobile
AndroidWidget AndroidiPhone/iPadWidget IOSApple WatchMac CatalystUniversal Windows 10 App
Autres
Procédures stockées
XMLNomElément (Fonction)
En anglais : XMLElementName
Renvoie le nom de l'élément en cours (balise ou attribut). Pour sélectionner un élément, utilisez les fonctions de recherche et de parcours XML (XMLPremier, XMLDernier, XMLFils, ...).
Exemple
NomBalise est une chaîne
// Récupère le nom de l'élément en cours
NomBalise = XMLNomElément("DocXML")
 
// Positionné sur un élément ?
SI NomBalise = "" ALORS
Erreur("Aucune balise en cours")
SINON
Info("Le nom de l'élément courant est : " + NomBalise)
FIN
 
// Autre possibilité :
 
// Positionné sur un élément ?
SI ErreurDétectée = Vrai ALORS
Erreur("Aucune balise en cours")
SINON
Info("Le nom de l'élément courant est : " + NomBalise)
FIN
Syntaxe
<Résultat> = XMLNomElément(<Document XML>)
<Résultat> : Chaîne de caractères
  • Nom de l'élément en cours.
  • Chaîne vide ("") si aucun élément n'est en cours. Dans ce cas, la variable ErreurDétectée est à Vrai. Pour obtenir plus de détails sur l'erreur, utilisez la fonction ErreurInfo.
<Document XML> : Chaîne de caractères
Nom du document XML manipulé. Ce document contient le code XML à analyser et a été créé avec la fonction XMLDocument.
Remarques

Connaître l'élément courant

  • Le type de l'élément en cours peut être connu avec la fonction XMLTypeElément.
  • La valeur de l'élément en cours peut être connue avec la fonction XMLDonnée.

Fonctions XML et threads

Si votre application utilise des threads, le document XML est partagé entre tous ces threads. Pour plus de détails sur la gestion des threads, consultez Gestion des threads.
Composante : wd280xml.dll
Version minimum requise
  • Version 9
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire