DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE


  • Fonctions modifiant XMLTrouve
  • Fonctions XML et threads
WINDEV
WindowsLinuxUniversal Windows 10 AppJavaEtats et RequêtesCode Utilisateur (MCU)
WEBDEV
WindowsLinuxPHPWEBDEV - Code Navigateur
WINDEV Mobile
AndroidWidget AndroidiPhone/iPadWidget IOSApple WatchMac CatalystUniversal Windows 10 App
Autres
Procédures stockées
XMLTrouve (Fonction)
En anglais : XMLFound
Vérifie si l'élément en cours correspond au parcours ou à la recherche en cours.
Exemple
// Rechercher la balise qui commence par "pri"
XMLRecherche("DocXML", "pri", XMLBalise + XMLSousElément, XMLCommencePar)
TANTQUE XMLTrouve("DocXML") = Vrai
Info("Balise trouvée " + XMLNomElément("DocXML"))
// Elément suivant dans la recherche
XMLSuivant("DocXML")
FIN
// Parcours d'un document
XMLPremier("DocXML")
// Balise trouvée ?
SI XMLTrouve("DocXML") = Vrai ALORS
Info("Balise courante : " + XMLNomElément("DocXML"))
FIN
Syntaxe
<Résultat> = XMLTrouve(<Document XML>)
<Résultat> : Booléen
  • Vrai si une fonction de parcours XML a pu se positionner sur un élément,
  • Faux dans le cas contraire (la position en cours dans le document XML n'est alors pas modifiée). La fonction XMLTrouve renvoie toujours le résultat opposé de la fonction XMLEnDehors.
<Document XML> : Chaîne de caractères
Nom du document XML manipulé. Ce document contient le code XML à analyser et a été créé avec la fonction XMLDocument.
Remarques

Fonctions modifiant XMLTrouve

Les fonctions suivantes modifient la valeur retournée par XMLTrouve :

Fonctions XML et threads

Si votre application utilise des threads, le document XML est partagé entre tous ces threads. Pour plus de détails sur la gestion des threads, consultez Gestion des threads.Si la position courante dans un document XML est modifiée dans un thread, la position courante dans ce document XML est modifiée pour tous les threads.
Composante : wd280xml.dll
Version minimum requise
  • Version 9
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire