PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE

  • Gestion des changements de pages
  • Fonctionnement dans des applications 64 bits
WINDEV
WindowsLinuxUniversal Windows 10 AppJavaEtats et RequêtesCode Utilisateur (MCU)
WEBDEV
WindowsLinuxPHPWEBDEV - Code Navigateur
WINDEV Mobile
AndroidWidget AndroidiPhone/iPadApple WatchUniversal Windows 10 AppWindows Mobile
Autres
Procédures stockées
Renvoie l'état de la source en cours.
nDefaut est un entier = 0

// Acquisition tant qu'il y a des pages dans le chargeur
nNumPage est un entier = 0
BOUCLE
// Numérisation dans un fichier BMP
SI TwainVersBMP("Fichier" + NumériqueVersChaîne(nNumPage + 1) + ".BMP",
Faux, // Pas d'interface utilisateur
nDefaut, // Image par défaut du périphérique
nDefaut, // Nombre de bits par pixel par défaut du périphérique
nDefaut, // Résolution de l'image par défaut du périphérique
nDefaut, // Contraste de l'image par défaut du périphérique
nDefaut, // Brillance de l'image par défaut du périphérique
Faux,  // Scanner le document d'un seul coté (pas de recto/verso)
Vrai // Optimiser le chargement automatiquement dans le chargeur
) = Faux ALORS
SORTIR
FIN
nNumPage ++
// Encore des pages ?
SI TwainEtat() = teNonChargé ALORS SORTIR
FIN
// Au moins une page de numérisée ?
SI nNumPage = 0 ALORS
Erreur("Échec de la numérisation", ErreurInfo())
SINON
Info(nNumPage + "pages ont été scannées")
FIN
Syntaxe
<Résultat> = TwainEtat()
<Résultat> : Réel
Etat de la source Twain correspondant à une des constantes suivantes :
teChargéGestionnaire Twain chargé.
teNonChargéGestionnaire Twain non chargé.
teOuvertGestionnaire Twain ouvert.
teSourceActifSource active.
teSourceOuvertSource ouverte.
teSourcePrêtSource prête à transférer les données.
teSourceTransfertSource en cours de transfert des données.
Remarques

Gestion des changements de pages

Pour réaliser une acquisition sur plusieurs pages en utilisant un périphérique TWAIN, il suffit de faire une boucle réalisant l'acquisition d'une page et se terminant lorsque la fonction TwainEtat retourne la constante teNonChargé. Cette valeur de la constante indique en effet que le chargeur de pages du périphérique TWAIN est vide.

Fonctionnement dans des applications 64 bits

Dans une application 64 bits, cette fonction utilisera automatiquement le driver Twain 64 bits. Si ce driver n'est pas installé, le périphérique TWAIN ne pourra pas être manipulé.
Composante : wd240std.dll
Version minimum requise
  • Version 9
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire