PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE

PV

  • Configuration nécessaire
WINDEV
WindowsLinuxUniversal Windows 10 AppJavaEtats et RequêtesCode Utilisateur (MCU)
WEBDEV
WindowsLinuxPHPWEBDEV - Code Navigateur
WINDEV Mobile
AndroidWidget AndroidiPhone/iPadWidget IOSApple WatchMac CatalystUniversal Windows 10 App
Autres
Procédures stockées
Renvoie les caractéristiques d'un périphérique de téléphonie. Permet de savoir si ce périphérique supporte les appels entrants de n'importe quel type, les appels vocaux et les appels fax.
Exemple
SI ETBinaire(telCapacité("LTP2"), telOptionTypeVoix) = telOptionTypeVoix ALORS
Info("Voix gérée")
FIN
 
SI ETBinaire(telCapacité("LTP2"), telOptionTypeFax) = telOptionTypeFax ALORS
Info("Fax géré")
FIN
Syntaxe
<Résultat> = telCapacité(<Nom du périphérique>)
<Résultat> : Entier ou constante de type entier
  • 0 en cas d'erreur,
  • une ou plusieurs des constantes suivantes :
    telOptionTypeFaxPériphérique acceptant les appels Fax
    telOptionTypeInconnuPériphérique acceptant les appels entrant de type inconnu.
    telOptionTypeVoixPériphérique acceptant les appels vocaux.
    Remarque : Les modems Fax autorisant la numérotation automatique peuvent renvoyer cette constante.
Pour identifier simplement le résultat, utilisez la fonction ETBinaire.
<Nom du périphérique> : Chaîne de caractères
Nom du périphérique à utiliser. La liste des périphériques de téléphonie est connue avec la fonction telListePériphérique.
Remarques

Configuration nécessaire

Les fonctions de téléphonie utilisent la technologie TAPI 2.0 et/ou la technologie TAPI 3.1. Ces technologies sont utilisables sur tous les systèmes.
Composante : wd280com.dll
Version minimum requise
  • Version 9
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire