PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE


  • Gestion des tabulations dans les rubriques
  • Gestion des Float lors d'un accès Oracle via ODBC
  • Récupération de rubriques de type Float sur Oracle (via ODBC)
WINDEV
WindowsLinuxUniversal Windows 10 AppJavaEtats et RequêtesCode Utilisateur (MCU)
WEBDEV
WindowsLinuxPHPWEBDEV - Code Navigateur
WINDEV Mobile
AndroidWidget AndroidiPhone/iPadApple WatchUniversal Windows 10 AppWindows Mobile
Autres
Procédures stockées
Gestion des tabulations dans les rubriques
Selon le type de parcours mis en place avec les fonctions SQL, la gestion des tabulations dans les rubriques sera différente :
Parcours de type : SQLPremier/SQLCol
Parcours de type : SQLAvance/SQLLitCol
Gestion des tabulationsCe type de parcours ne permet pas de récupérer les tabulations présentes dans les valeurs des enregistrements. Une tabulation sépare deux rubriques. Seule la partie précédant la tabulation sera récupérée avec les fonctions de lecture.
Pour plus de détails, consultez l'aide de SQLCol et SQLAssocie.
Ce type de parcours permet de récupérer les tabulations présentes dans les valeurs des enregistrements.
Pour plus de détails, consultez l'aide de SQLLitCol.
Exemple
ResExec = SQLExec("SELECT NOMCLI " + ...
"FROM FACT", "REQ1")  
SI ResExec=Vrai ALORS  
SQLPremier("REQ1")  
// Transfert du nom dans
// LISTE_NOM
TANTQUE PAS SQL.EnDehors
ListeAjoute(LISTE_NOM, ...
SQLCol("REQ1" ,1))
SQLSuivant("REQ1")  
FIN  
SINON  
// TraiteErreur  
FIN  
SQLFerme("REQ1")
i est un entier = 0
SQLExec("SELECT NOM, PRENOM," + ...
"POSTE,PHOTO FROM CLIENT", ...
"REQ1" )  
// Récupérer la requête ligne à ligne
TANTQUE SQLFetch("REQ1") = 0
// Il y a encore une ligne  
i++  
// Récupérer les données  
NOM[i] = SQLLitCol("REQ1", 1)  
PRENOM[i] = SQLLitCol("REQ1", 2)
POSTE[i] = SQLLitCol("REQ1", 3)
{"IMAGE" +i} = ...  
SQLLitMémo("REQ1", 4)
FIN
SQLFerme("REQ1")
Pour plus de détails sur les différents types de parcours, consultez Types de parcours SQL.
Gestion des Float lors d'un accès Oracle via ODBC

Récupération de rubriques de type Float sur Oracle (via ODBC)

Par défaut, le séparateur décimal utilisé pour les rubriques de type Float sur Oracle est le point. Or le driver ODBC renvoie la valeur avec en utilisant la virgule comme séparateur décimal. Lors de l'affectation de la valeur dans un champ de type numérique, les décimales sont perdues.
Pour éviter ce problème, il suffit de configurer le séparateur décimal pour la connexion en cours :
// Connexion à la base de données Oracle  
SQLConnecte("MaBaseOracle", "User", "Passe", "", "ODBC")  
// Requête pour changer le séparateur décimal  
SQLExec("ALTER SESSION SET NLS_NUMERIC_CHARACTERS ='. '", "ReqTemp")
Version minimum requise
  • Version 9
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire