DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE

  • Connexion avec une analyse HFSQL
  • Divers
WINDEV
WindowsLinuxUniversal Windows 10 AppJavaEtats et RequêtesCode Utilisateur (MCU)
WEBDEV
WindowsLinuxPHPWEBDEV - Code Navigateur
WINDEV Mobile
AndroidWidget AndroidiPhone/iPadWidget IOSApple WatchMac CatalystUniversal Windows 10 App
Autres
Procédures stockées
Ferme la connexion en cours et libère l'espace mémoire utilisé par la connexion. La fonction SQLDéconnecte doit être appelée systématiquement pour fermer la connexion, même si cette connexion a échoué.
Exemple
HFSQLHFSQL Client/Serveur
// Exemple attaché à l'analyse GESCOM
// TABLE_TableReq est un champ Table par programmation
ResConnect est un entier
ResExec est un booléen
MaBase est une chaîne = "C:\GESCOM.WDD"
ResConnect = SQLConnecte(MaBase, "", "")
SI ResConnect <> 0 ALORS
ResExec = SQLExec("SELECT NOM, VILLE FROM POP", "REQ1")
SI ResExec = Vrai ALORS
// Récupérer les données dans la table
SQLTable("REQ1", TABLE_TableReq)
SINON
// Erreur d'exécution de la requête
// Récupérer les informations relatives à la requête exécutée
SQLInfoGene("REQ1")
Erreur(SQL.MesErreur)
FIN
// Libérer la requête dans tous les cas
SQLFerme("REQ1")
SINON
 // Erreur de connexion
 Erreur("La connexion à la base" + MaBase + "a échoué")
FIN
// Libérer la requête dans tous les cas
SQLDéconnecte()
Syntaxe
SQLDéconnecte()
Remarques
HFSQLHFSQL Client/Serveur

Connexion avec une analyse HFSQL

Dans le cas d'une connexion avec une analyse HFSQL, la fonction SQLDéconnecte ferme l'analyse (équivalent à la fonction HFermeAnalyse). Ainsi, pour continuer à manipuler les fichiers de l'analyse, il faut ouvrir l'analyse avec la fonction HOuvreAnalyse.

Divers

  • Une seule connexion peut être en cours à un moment donné.
  • La libération de mémoire allouée lors de la connexion (exécution de "SQLFreeConnect") est automatiquement gérée.
Composante : wd280hf.dll
Version minimum requise
  • Version 9
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire