PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE

PV

WINDEV
WindowsLinuxUniversal Windows 10 AppJavaEtats et RequêtesCode Utilisateur (MCU)
WEBDEV
WindowsLinuxPHPWEBDEV - Code Navigateur
WINDEV Mobile
AndroidWidget AndroidiPhone/iPadWidget IOSApple WatchMac CatalystUniversal Windows 10 App
Autres
Procédures stockées
Exécutée sur le poste serveur, cette fonction permet d'attendre une demande de connexion provenant de sockets clients.
Remarques :
  • Si le poste client utilise une application WINDEV pour se connecter à ce socket, la demande de connexion est effectuée par la fonction SocketConnecte.
  • Socket de type UDP : La fonction SocketAttendConnexion ne peut pas être utilisée avec des sockets de type UDP.
Rappel : Un socket est une ressource de communication utilisée par les applications pour communiquer d'une machine à une autre sans se soucier du type de réseau.
Exemple
Etats et Requêtes
// Crée un socket sur le poste serveur
SI SocketCrée("Serveur", 8000) = Faux ALORS
Erreur("Erreur de création " + ErreurInfo(errMessage))
SINON
// Gestion des connexions des postes clients dans un thread
ThreadExécute("Thread1", threadNormal, ProcédureAttente)
FIN
 
 
PROCÉDURE INTERNE ProcédureAttente()
SI SocketAttendConnexion("Serveur") ALORS
Canal est une chaîne
// Si la connexion est acceptée,
// la gestion de cette connexion est réalisée dans un thread spécifique
Canal = SocketAccepte("Serveur")
ThreadExécute(Canal, threadNormal, ProcédureGestion, Canal)
SINON
SI PAS SocketExiste("Serveur") ALORS
        SORTIR
FIN
FIN
FIN
Syntaxe
<Résultat> = SocketAttendConnexion(<Nom du socket> [, <Durée maximale>])
<Résultat> : Booléen
  • Vrai : une nouvelle demande de connexion est en attente.
  • Faux : aucune demande de connexion n'a été détectée.
<Nom du socket> : Chaîne de caractères
Nom du socket serveur qui attend la connexion.
<Durée maximale> : Entier optionnel ou Durée optionnelle
Durée d'attente maximale (en millisecondes).
  • Cette fonction est bloquante pendant la durée indiquée ou jusqu'à la détection d'une demande de connexion.
  • Si ce paramètre n'est pas précisé, la fonction est bloquante jusqu'à la prochaine tentative de connexion.
Remarque : si cette fonction est utilisée en multi-thread, la fonction ne bloque que le thread dans lequel elle est appelée.
Ce paramètre peut correspondre à :
  • un entier correspondant au nombre de millisecondes,
  • une variable de type Durée,
  • l'indication directe de la durée (par exemple 1 s ou 10 ms).
Remarques
Composante : wd270com.dll
Version minimum requise
  • Version 9
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire